Disclaimer

This report was prepared as an account of work sponsored by an agency of the United States Government. Neither the United States Government nor any agency thereof, nor any of their employees, makes any warranty, express or implied, or assumes any legal liability or responsibility for the accuracy, completeness, or usefulness of any information, apparatus, product, or process disclosed, or represents that its use would not infringe privately owned rights. References herein to any specific commercial product, process, or service by trade name, trademark, manufacturer, or otherwise does not necessarily constitute or imply its endorsement, recommendation, or favoring by the United States Government or any agency thereof. The views and opinions of authors expressed herein do not necessarily state or reflect those of the United States Government or any agency thereof.
FORWARD

This *Battery Life Estimator Manual* was prepared for the United States Department of Energy (DOE), Office of Energy Efficiency and Renewable Energy (EERE), Vehicle Technologies Program. It is intended to assist developers in successfully estimating battery life capability for electric, hybrid-electric, or plug-in hybrid electric vehicle applications based on accelerated performance and life characterization using the procedures that have been defined in the previously published DOE testing manuals. The original publication of this *Battery Life Estimator Manual* included life estimation techniques based on a default linearizable model. In Revision 1, a default nonlinear model is also included as well as a rate-based degradation model that can be useful in assessing memory effects during aging under non-isothermal conditions. A software package (“BatteryLife.exe”) has also been developed based on the methodologies and default models that are described in this manual; software licenses can be obtained from Argonne National Laboratory.

The DOE-United States Advanced Battery Consortium, Electrochemical Energy Storage Technical Advisory Committee supported the development of this manual. Technical team point of contacts responsible for its development and revision are Jon P. Christophersen of Idaho National Laboratory (INL), Ira Bloom of Argonne National Laboratory (ANL), Edward Thomas of Sandia National Laboratories (SNL), and Vincent Battaglia of Lawrence Berkeley National Laboratory (LBNL).

The development of this manual was funded by the United States Department of Energy, Office of Energy Efficiency and Renewable Energy, Vehicle Technologies Program. Technical direction from DOE was provided by David Howell, Energy Storage R&D Manager and Hybrid Electric Systems Team Leader, and Brian Cunningham, Energy Storage Testing, Design, and Analysis Program Manager.

Comments and questions regarding this manual should be directed to Jon P. Christophersen at the Idaho National Laboratory (*jon.christophersen@inl.gov*). Comments and questions regarding the Battery Life Estimation software tool should be directed to Ira Bloom at the Argonne National Laboratory (*ira.bloom@anl.gov*).
CONTENTS

GLOSSARY OF TERMS ............................................................................................................. xiii

ACRONYMS .............................................................................................................................................. xv

1. INTRODUCTION ................................................................................................................................. 1
   1.1 Purpose and Applicability ........................................................................................................ 1
   1.2 Manual Organization ........................................................................................................... 2

2. METHODOLOGY FOR ESTIMATING CALENDAR-LIFE ........................................................... 3
   2.1 Generalized Model ................................................................................................................. 3
   2.2 Linearizable Degradation Model ........................................................................................... 4
   2.3 Nonlinear Degradation Model ............................................................................................... 4
   2.4 Error Model ............................................................................................................................ 5
      2.4.1 Estimated Error Model ........................................................................................ 5
      2.4.2 Independent Assessment of Measurement Error ................................................. 6
   2.5 Robust Regression .................................................................................................................... 7
   2.6 Life Prediction ........................................................................................................................ 7
   2.7 Monte Carlo Simulations ....................................................................................................... 8
   2.8 Lack-of-fit Statistic ............................................................................................................... 10
   2.9 Application to Calendar Life Data ....................................................................................... 11

3. APPLICATION ................................................................................................................................. 12
   3.1 Experimental ........................................................................................................................ 12
   3.2 Linearizable Model .............................................................................................................. 13
   3.3 Nonlinear Model ................................................................................................................. 17

4. RATE-BASED DEGRADATION MODELING ............................................................................. 21
   4.1 Methodology ........................................................................................................................ 21
   4.2 Application: Non-Isothermal Aging .................................................................................... 23
      4.2.1 Experimental.............................................................................................................. 23
      4.2.2 Results ....................................................................................................................... 25
5. BATTERY LIFE ESTIMATION SOFTWARE

5.1 System Requirements ........................................................................................................... 29
5.2 Battery Life User Interface .................................................................................................. 29
5.3 Equation Requirements ........................................................................................................ 30
5.4 Data Formatting Requirements ............................................................................................ 30
5.5 Software Navigation ............................................................................................................ 31
  5.5.1 File Menu ....................................................................................................................... 31
  5.5.2 Edit Menu ....................................................................................................................... 32
  5.5.3 Run Menu ....................................................................................................................... 33
  5.5.4 View Menu ..................................................................................................................... 33
  5.5.5 Help Menu ..................................................................................................................... 36
5.6 Using the Software ............................................................................................................... 37
  5.6.1 Creating or Opening an Existing Fit/Simulation File ..................................................... 37
  5.6.2 Fitting and Simulation ..................................................................................................... 38
  5.6.3 Fit Wizard ....................................................................................................................... 40
  5.6.4 Simulation Wizard .......................................................................................................... 46
  5.6.5 Model Fit Results ........................................................................................................... 49
  5.6.6 Monte Carlo Simulation Results ...................................................................................... 51
  5.6.7 Report Preview ............................................................................................................... 56
5.7 Troubleshooting ................................................................................................................... 57
  5.7.1 Text-entry boxes and/or buttons are not in the correct positions or
        appear to be crowded ........................................................................................................ 57
  5.7.2 The application is running on a network and an error occurs when
        trying to open a Life file ....................................................................................................... 57
6. REFERENCES ......................................................................................................................... 58

Appendix A—Methods for Estimating the Parameters of Linear Models ........................................ 61
Appendix B—Methods for Estimating the Parameters of Nonlinear Degradation Models ............... 66
FIGURES

Figure 1. Fitted linearized model versus experimental data ................................................................. 14

Figure 2. Fitted error model for linearizable case .................................................................................. 15

Figure 3. Histogram of simulated life capability using 1000 bootstrap trials for the linearizable model .......................................................................................................................... 16

Figure 4. Estimate mean cell life capability with statistical confidence levels for the linearizable model .......................................................................................................................... 16

Figure 5. Fitted nonlinear model versus experimental data ...................................................................... 17

Figure 6. Fitted error model for nonlinear case ....................................................................................... 19

Figure 7. Histogram of simulated life capability using 1000 bootstrap trials for the nonlinear model .......................................................................................................................... 20

Figure 8. Estimate mean cell life capability with statistical confidence levels for the nonlinear model .......................................................................................................................... 20

Figure 9. Calendar-life pulse-per-day profile (Reference 1) .................................................................... 24

Figure 10. Simple rate-based model fit to the INL experimental data .................................................... 25

Figure 11. Generalized rate-based model fit to the INL experimental data ............................................. 27

Figure 12. Hourly temperature profile: Phoenix, AZ, Calendar year 2010 ............................................. 27

Figure 13. Predicted rise in relative resistance ....................................................................................... 28

Figure 14. Cumulative distribution function of predicted mean life from bootstrap ............................. 28

Figure 15. A screen view of the “Battery Life Estimation” desktop ....................................................... 29

Figure 16. File menu ............................................................................................................................. 31

Figure 17. Edit menu ............................................................................................................................. 32

Figure 18. Run menu ............................................................................................................................. 33

Figure 19. View menu and model results sub-menu ............................................................................. 33

Figure 20. View menu and plot sub-menu ............................................................................................. 34

Figure 21. View menu and data sub-menus .......................................................................................... 35

Figure 22. Input data display ................................................................................................................ 36

Figure 23. Monte Carlo simulation data display .................................................................................... 36
Figure 24. Software help file ................................................................. 37
Figure 25. File selection dialog box .................................................... 38
Figure 26. Include/exclude dataset(s) dialog box ................................. 39
Figure 27. Editing the lower confidence limit ....................................... 40
Figure 28. Typical display to define the data in a file ........................... 41
Figure 29. Typical display to associate data and variables .................. 42
Figure 30. Available algebraic functions ............................................. 43
Figure 31. Typical display to specify equations and variable transforms for a linearizable model .......... 44
Figure 32. Typical display to select a data file ..................................... 45
Figure 33. Typical display to open an Excel file ................................. 45
Figure 34. Typical display for selecting the sheet and columns from an EXCEL data file ...................... 45
Figure 35. Selecting which stress factors to include in the fit calculation ......................................................... 46
Figure 36. Display allowing entry of simulation parameters .................. 48
Figure 37. Experimental conditions and Monte Carlo parameter entry ........................................................................ 49
Figure 38. Example results from fitting display .................................... 50
Figure 39. Example CDF curve ............................................................. 51
Figure 40. Life estimate display using experimental data ...................... 51
Figure 41. Typical life projection result display from Monte Carlo simulation ......................................................... 52
Figure 42. Experimental data and fitted curves ..................................... 52
Figure 43. Error model results ............................................................... 53
Figure 44. Difference between average and predicted performance vs. predicted performance .............. 54
Figure 45. Predicted performance behavior vs. the average measured performance ................................. 54
Figure 46. Cell distribution bar chart .................................................. 55
Figure 47. Cell distribution bar chart as a smooth curve ...................... 55
Figure 48. Report print preview ............................................................ 56
Figure 49. Network error box ............................................................... 57
TABLES

Table 3.1. SAFT VL7P cell test matrix .................................................................................................12

Table 4.1. Integrating the derivative function numerically......................................................................22

Table 4.2. Sanyo SA cell test matrix for memory study...........................................................................24

Table 5.1. Example of data containing a missing measurement.............................................................31
GLOSSARY OF TERMS

Beginning of Life (BOL) – The point in time at which life testing begins. A distinction is made in this manual between the performance of a battery at this point and its initial performance, because some degradation may take place before the start of life testing. Analysis of the effects of life testing is based on changes from the BOL performance.

Calendar Life – The time required to reach end of life at the reference temperature at open-circuit (corresponding to key-off/standby conditions in the vehicle).

Cycle Life – The number of consecutive cycles consisting of a charge neutral combination of discharge and charge pulses centered on a given state-of-charge for Hybrid Electric Vehicles (HEVs) or between given voltage limits for Plug-in Electric Vehicles and Electric Vehicles (PHEVs and EVs) required to reach end of life at the reference temperature.

Degradation Model – An empirical- or chemistry/physics-based model that describes the expected degradation of a battery experiencing typical stress conditions.

Depth of Discharge (DOD) – The percentage of a device’s rated capacity removed by discharge relative to a fully charged condition, normally referenced to a constant current discharge at the C1/1 rate. The capacity to be used is established (fixed) at the beginning of testing, %.

End of Life (EOL) – A condition reached when the device under test is no longer capable of meeting the applicable USABC goals. This is normally determined from RPT results, and it may not coincide exactly with the ability to perform the life test profile (especially if cycling is done at elevated temperatures.) The number of test profiles executed at end of test is not necessarily equal to the cycle life per the USABC goals.

End of Test (EOT) – The point in time where life testing is halted, either because criteria specified in the test plan are reached, or because it is not possible to continue testing.

Error Model – A model that accounts for the difference between the measured and expected performance. The error model combines the effects of both measurement error and manufacturing variability.

Lack of Fit Statistic – A statistic that measures the implausibility of the observed data given the assumed degradation and error models. The statistic compares the differences between the observed average response (e.g., relative resistance) within each treatment/group and the response for that group that is predicted by the degradation model. The differences are normalized by the within-group standard deviation predicted by the error model. The sum of the differences
forms the lack of fit statistic. Abnormally large values of the statistic indicate lack of fit.

*Memoryless Degradation* – A process wherein the degradation rate of a cell depends only on its present state and present stress levels.

*Reference Performance Test (RPT)* – A periodic assessment of battery degradation during life testing. A reference performance test will typically yield capacity fade, power fade, and impedance rise as a function of test time.

*State of Charge (SOC)* – The available capacity in a battery expressed as a percentage of actual capacity. This is normally referenced to a constant current discharge at the \( C_{1/1} \) rate. For this manual, it may also be determined by a voltage obtained *via* a relationship of capacity to voltage established at beginning of life. \( \text{SOC} = (100 - \text{DOD}) \) if the rated capacity is equal to the actual capacity, %.

*Stress Factors* – The parameters that are used to accelerate aging of a battery technology, such as temperature, state-of-charge, throughput, and pulse power. These are the explanatory variables in the degradation model.
<table>
<thead>
<tr>
<th>Acronym</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANL</td>
<td>Argonne National Laboratory</td>
</tr>
<tr>
<td>BLE</td>
<td>Battery Life Estimator</td>
</tr>
<tr>
<td>BOL</td>
<td>beginning of life</td>
</tr>
<tr>
<td>CDF</td>
<td>cumulative distribution function</td>
</tr>
<tr>
<td>CSV</td>
<td>comma separated value</td>
</tr>
<tr>
<td>DOD</td>
<td>depth of discharge</td>
</tr>
<tr>
<td>DOE</td>
<td>Department of Energy</td>
</tr>
<tr>
<td>EERE</td>
<td>Energy Efficiency and Renewable Energy</td>
</tr>
<tr>
<td>EOL</td>
<td>end of life</td>
</tr>
<tr>
<td>EOT</td>
<td>end of test</td>
</tr>
<tr>
<td>EV</td>
<td>electric vehicle</td>
</tr>
<tr>
<td>HEV</td>
<td>hybrid electric vehicle</td>
</tr>
<tr>
<td>HPPC</td>
<td>hybrid pulse power characterization</td>
</tr>
<tr>
<td>INL</td>
<td>Idaho National Laboratory</td>
</tr>
<tr>
<td>LBNL</td>
<td>Lawrence Berkeley National Laboratory</td>
</tr>
<tr>
<td>LCL</td>
<td>lower confidence limit</td>
</tr>
<tr>
<td>LOF</td>
<td>lack of fit</td>
</tr>
<tr>
<td>MAV</td>
<td>median absolute value</td>
</tr>
<tr>
<td>PHEV</td>
<td>plug-in hybrid electric vehicle</td>
</tr>
<tr>
<td>RPT</td>
<td>reference performance test</td>
</tr>
<tr>
<td>SEI</td>
<td>solid electrolyte interphase</td>
</tr>
<tr>
<td>SNL</td>
<td>Sandia National Laboratories</td>
</tr>
<tr>
<td>SOC</td>
<td>state of charge</td>
</tr>
<tr>
<td>SS</td>
<td>sum of squares</td>
</tr>
<tr>
<td>TLVT</td>
<td>Technology Life Verification Testing</td>
</tr>
<tr>
<td>UCL</td>
<td>upper confidence limit</td>
</tr>
<tr>
<td>USABC</td>
<td>United States Advanced Battery Consortium</td>
</tr>
</tbody>
</table>
Battery Calendar Life Estimator Manual

1. INTRODUCTION

1.1 Purpose and Applicability

The purpose of this Battery Life Estimator (BLE) Manual is to assist developers in their efforts to determine the life capability of advanced battery technologies for automotive applications. Testing requirements and procedures have been previously defined in various manuals (e.g., References 1 through 4) published under the United States Advanced Battery Consortium (USABC). This manual describes a standardized method for determining the calendar life capability of battery technologies with a high degree of statistical confidence based on models and degradation data acquired from typical USABC performance testing.

A software package (“BatteryLife.exe”) has also been developed to estimate calendar life capability based on the methodology described herein. To acquire the software, users must first download and sign the license agreement at http://www.anl.gov/techtransfer/Software_Shop/TLVT/TLVT.html. USABC developers can license the software at no cost, but others will have to pay a nominal fee. The degradation models presented in this manual have been included as default options for quick implementation to a set of data. However, the software can also accommodate other degradation models that are applicable to a particular chemistry.

The offline battery life estimation methods provided in this manual and associated software tool are typically performed during Stage 1 or Stage 2 testing as defined in the Technology Life Verification Testing Manual (TLVT, Reference 5). Stage 1 testing consists of short-term screening studies of a battery technology to assess its performance capability relative to the USABC targets. Applied examples of battery life estimation based on Stage 1 testing for a set of experimental cells are provided in References 6 and 7. Stage 2 testing assumes a reasonably mature cell chemistry that is subjected to accelerated aging techniques to demonstrate its readiness for transition to production. Battery life estimation techniques could also be applied for Stage 3 testing, where complete battery systems are assessed for implementation and projected warranty costs, but other critical variables should be included within the models (e.g., cell balancing, thermal management, etc.). Stage 4 is for online battery health assessment, which can use the models and offline life estimation results as a baseline to gauge performance capability.

This manual specifically covers calendar-life estimations based on a default linearizable or nonlinear battery degradation model and associated error model. However, the software tool also provides an option to estimate cycle-life capability with performance degradation as a function of cycle number. The resulting life estimation will be based on the total number of cycles a battery is predicted to be able to complete at a given stress factor (i.e., temperature or state-of-charge).
1.2 Manual Organization

This manual is organized into five main sections. Section 2 describes the default statistical models implemented in the software tool (both linearizable and nonlinear forms) as well as the methods for estimating model parameters and cell life from experimental data. This section also presents a methodology for assessing the uncertainty of the estimated cell life using Monte Carlo simulations. Section 3 demonstrates the capabilities of both the linearizable and nonlinear models when applied to a set of experimental data. Section 4 describes a rate-based modeling approach that could be applied when steady state conditions are not present and provides an example of how this model could be implemented using a set of experimental cells that were aged under non-isothermal conditions. Section 5 is a user’s guide for the software tool (“BatteryLife.exe”) and provides details on data formatting, menu navigation, and data processing. Appendix A is an extended discussion of parameter estimation using robust regression techniques.
2. METHODOLOGY FOR ESTIMATING CALENDAR-LIFE

This section describes a methodology for estimating the average calendar life capability of various cell technologies and assessing their readiness for transition to production. Consequently, the emphasis is placed on predicting the capability of typical (i.e., representative) cells to meet the USABC target of a 15-year calendar life. A two-part model can be constructed from the experimental test data. The first part is the degradation model that represents the average cell performance as a function of aging over a range of stress conditions. The second part is the error model that represents the deviation of the cell behavior relative to the average performance. The degradation model provides a basis for the estimation of average cell life and the error model provides a basis for assessing the accuracy of the degradation model.

The degradation model can be empirical, chemistry/physics-based, or some combination of both (i.e., semi-empirical). A wide variety of model forms are possible. The specific form of the model will necessarily depend on the particular technology and set of stress factors. For Stage 1 and Stage 2 testing, as defined in the TLVT Manual (Reference 5), there will generally be incomplete knowledge of the specific degradation mechanisms or the source of the deviations between average performance and actual measured performance. Thus, relatively simple empirical or semi-empirical models with few parameters should be used for life estimation, though physics-based models could also be used if they are available. Simple forms of a degradation model and error model that have been successfully implemented for a variety of technologies are illustrated herein. The methodology for estimating model parameters, assessing model accuracy, and estimating mean cell life with associated uncertainty are also described.

2.1 Generalized Model

The use of accelerated degradation testing to verify life capability requires the selection of performance measures that accurately reflect battery state of health (Reference 5). An example performance measure is relative resistance (i.e., the cell resistance at time $t$ divided by the resistance at beginning of life, $t = 0$). The generalized model must relate the measured cell performance at any given time to a combination of the stress factors. For example, in the case of calendar-life experiments with a single stress factor of temperature, the acquired data can be represented generically by the model shown in Equation (1), where $Y_i(T; t)$ represents the measured performance (e.g., relative resistance) of the $i^{th}$ cell in the test matrix after being subjected to aging for time $t$ at temperature $T$ (Reference 6). The average cell performance is represented by a degradation model, $\mu(T; t)$, which may be in a linearizable form (Section 2.2) or a nonlinear form (Section 2.3). The combined effects that are related to the unique behavior of the $i^{th}$ individual cell and measurement error are represented by an error model $\gamma_i(T; t)$, which is described in Section 2.4.

$$Y_i(T; t) = \mu(T; t) + \gamma_i(T; t)$$  \hspace{1cm} (1)
2.2 Linearizable Degradation Model

In the example case of a single stress factor (temperature), a simple but useful form for a linearizable degradation model is given by Equation (2), where $\beta_0$, $\beta_1$, and $\rho$ represent the model parameters (Reference 6). This is a semi-empirical model that combines the observed behavior from acquired test data with a chemistry/physical basis. In the generic case, the physical basis of this model comes from an assumed Arrhenius behavior (i.e., $\exp(1/T)$), which is a thermally activated process. When the observed degradation has a square-root of time dependence (i.e., $\rho = 0.5$), the model describes a diffusion controlled process that is governed by parabolic kinetics.

$$\mu(T;t) = 1 + \exp\left(\beta_0 + \beta_1 \cdot \frac{1}{T}\right) \cdot t^\rho$$

(2)

Note that $\mu(T;t) = 1$ for $t = 0$ and then increases in value as the cell ages. Various normalized responses, including relative resistance, are consistent with these conditions. If the natural response decreases to zero as a function of cell age, $\mu(T;t)$ can be considered as a model for the inverse of the natural response. Examples of a naturally decreasing response include relative power and relative capacity. In such cases, $\mu(T;t)$ can be considered as a model for inverse relative power or inverse relative capacity.

To estimate the parameters associated with this degradation model, it is useful to re-express the model in a linear form with a log transformation as shown in Equation (3). Once the model has been linearized, robust regression can be used to estimate the model parameters using the methods described in Section 2.5.

$$\log(\mu(T;t) - 1) = \beta_0 + \beta_1 \cdot \frac{1}{T} + \rho \cdot \log(t)$$

(3)

A generalized form of the linearizable degradation model is shown in Equation (4). This model form assumes multiple stress factors, $X_1, X_2, \ldots, X_n$, as a function of test time. As discussed in the TLVT Manual (Reference 5), these stress factors can include temperature, state-of-charge (SOC), throughput, and pulse power ratings. The corresponding model parameters are $\beta_0, \beta_1, \beta_2, \ldots, \beta_n$ and $\rho$.

$$\mu(X_1, X_2, \ldots, X_n; t) = 1 + \exp\left(\beta_0 + \beta_1 X_1 + \beta_2 X_2 + \ldots + \beta_n X_n\right) \cdot t^\rho$$

(4)

2.3 Nonlinear Degradation Model

Some battery performance data are not easily fit with a linearizable model. A nonlinear degradation model is shown in Equation (5) using the example case of a single stress factor (temperature), where $\beta_0$, $\beta_1$, and $\rho$ represent the model parameters. This model form is also semi-empirical and the physical basis comes from a logistic growth
perspective, where the change in the degradation parameter becomes limited by the lack of reactive materials. Specific applications of this model can vary depending on the observed trends in the performance data. The generalized form for this nonlinear model with additional stress factors is shown in Equation (6).

\[
\mu(T;t) = \left[1 + \exp\left\{\beta_0 + \beta_1 \frac{1}{T}\right\}\cdot t\right]^\rho
\]

\[
\mu(X_1, X_2, \ldots, X_n; t) = \left[1 + \exp\left\{\beta_0 + \beta_1 X_1 + \beta_2 X_2 + \ldots + \beta_n X_n\right\}\cdot t\right]^\rho
\]

For this nonlinear form, model parameters are estimated with the Levenberg-Marquardt method (References 8 and 9). The Levenberg-Marquardt method is an iterative algorithm that is used to find the minimum of a nonlinear function. When used in the context of curve fitting, this method minimizes the least-squares errors between the data and the objective function, \(f\), and can be expressed as shown in Equation (7), where \(J\) is the matrix of gradients of \(f\) with respect to each \(\beta\), \(\beta\) is a parameter of \(f(x, \beta)\), \(\lambda\) is a dampening factor, \(\delta\) is an incremental change in \(\beta\), and \(y\) is the observation at \(x\) (Reference 9). For this implementation, the Levenberg-Marquardt method uses the same robust regression techniques described in Section 2.5 to make it less sensitive to outliers and to estimate errors.

\[
\left[\left(J^T J\right) + \lambda \text{diag}(J^T J)\right] \delta = J^T [y - f(\beta)]
\]

### 2.4 Error Model

The error model accounts for the difference between the measured performance and expected performance. The difference is a combination of effects due to measurement error as well as physical and chemical variations in cell manufacturing. Two different approaches for determining the measurement error are discussed in this section. One method estimates the error from the measured data, and the other method independently determines the error based on calibration and accuracy checks of the test equipment. The software tool (“BatteryLife.exe”) provides both options to the user for life prediction.

#### 2.4.1 Estimated Error Model

In the example case of a single stress factor (temperature), a useful form for the estimated error model (Reference 6) is given by Equation (8), where \(\delta_i\) represents a random, cell-specific, proportional effect with variance \(\sigma^2_{\delta_i}\), and \(\pi_i(t)\) represents the effects of measurement error on \(Y_i(T;t)\).

\[
\gamma_i(T;t) = \delta_i \cdot (\mu(T;t) - 1) + \pi_i(t)
\]
Using relative resistance as the performance measure, the expression for $Y_i(T;t)$ is as shown in Equation (9), where $R_{\text{true}}(i,t)$ is the unknown (but true) value of the resistance of the $i^{th}$ cell at time $t$, and $\varepsilon_i(t)$ is the specific unknown error associated with that measurement.

$$Y_i(T;t) = \frac{R_{\text{true}}(i,t) + \varepsilon_i(t)}{R_{\text{true}}(i,0) + \varepsilon_i(0)}$$  (9)

The resulting error model due to measurement effects is shown in Equation (10).

$$\pi_i(t) = \frac{R_{\text{true}}(i,t) + \varepsilon_i(t)}{R_{\text{true}}(i,0) + \varepsilon_i(0)} - \frac{R_{\text{true}}(i,t)}{R_{\text{true}}(i,0)}$$  (10)

It is assumed that the measurement errors are independent with a relative standard deviation of $\sigma_{\varepsilon}$ (i.e., $\sigma_{\varepsilon} = \alpha \cdot R_{\text{true}}(i,0)$). With this and other assumptions (Reference 6), the variance of $\pi_i(t)$, given by $\sigma_{\pi_i}^2$, can be approximated by $2 \cdot \alpha^2$.

Assuming that the mean values of $\varepsilon_i(t)$ and $\delta_i$ are zero, then within a given group of cells that have experienced the same stresses and aging time, the mean and variance of $Y_i(T;t)$ can be expressed as shown in Equations (11) and (12). Robust regression (see Section 2.5) is used to estimate the variance model parameters ($\sigma_{\varepsilon}^2$ and $\sigma_{\pi}^2$).

$$\text{Mean}(Y_i(T;t)) = \mu(T;t)$$  (11)

$$\text{Var}(Y_i(T;t)) = \text{Var}(Y_i(T;t)) \approx \sigma_{\varepsilon}^2 \cdot (\mu(T;t) - 1)^2 + \sigma_{\pi}^2$$  (12)

Thus, this model of the variance within a treatment group and Reference Performance Test (RPT) (References 1-4), implies that the expected variability in cell performance increases as the expected level of degradation increases.

### 2.4.2 Independent Assessment of Measurement Error

Alternatively, the magnitude of measurement error can be estimated directly using the uncertainty methodology developed at the Idaho National Laboratory (References 10 and 11). First, the effect of measurement error can be minimized with test equipment calibration and verification. Calibration can be performed using the manufacturer’s recommended procedures. Verification consists of independent measurements of test channel voltage and current outputs at various levels within the channel full scale operating range. The total equipment and channel error can then be determined by the measured data and the uncertainties of the independent measurement equipment (i.e., a digital voltmeter and shunt for current measurements). If the results from this analysis show poor accuracy or repeatability, the test equipment should be calibrated and verified.
again until the results are less than or equal to the claimed values of the manufacturer (e.g., 0.02% of full scale repeatability).

These data are also useful in determining the uncertainty range of the performance parameters of interest for the life prediction model. Each performance parameter (e.g., resistance, power, capacity, and energy) is a function of voltage and current measurements (temperature uncertainty is treated elsewhere). The uncertainty expression associated with that performance parameter can be determined based on the accuracy and precision of the voltage and current measurements as determined during the initial calibration or in-test calibration checks, and low-order Taylor Series approximations of the performance parameter with respect to the independent voltage and current measurements. For example, the uncertainty expression for resistance as defined in the USABC Manuals (References 1-4) is given by Equation (13), where \( V_{FS} \) and \( I_{FS} \) are the test channel’s full scale voltage and current range, respectively; \( \% \text{err}_{V_{CAL}} \) and \( \% \text{err}_{I_{CAL}} \) are the calibration errors due to the independent digital voltmeter and shunt used to measure the accuracy during the calibration check; and \( \% \text{err}_{V_{STD}} \) and \( \% \text{err}_{I_{STD}} \) are the standard deviations determined experimentally from the accuracy measurements.

\[
\% R_s = \left[ 2 \left( \frac{\% \text{err}_{V_{STD}}}{V(t_a) - V(t_b)} V_{FS} \right)^2 + 2 \left( \frac{\% \text{err}_{I_{STD}}}{I(t_a) - I(t_b)} I_{FS} \right)^2 + (\% \text{err}_{V_{CAL}})^2 + (\% \text{err}_{I_{CAL}})^2 \right]^{1/2} \quad (13)
\]

### 2.5 Robust Regression

The parameters associated with both the degradation and error models are estimated with a robust regression procedure because it has reduced sensitivity to anomalous data (i.e., outliers). Consequently, the parameter estimates are not greatly affected by the outliers. Robust regression procedures also are valuable when the error variance is not constant across the experimental space, as is the case for the assumed error model in Section 2.4. The particular procedure implemented in this manual includes three iterations of weighted least-squares regression (Reference 12). For the first iteration, ordinary least-squares regression is used (i.e., the relative weights are identical). For subsequent iterations, the weights are based on Tukey’s biweight function (Reference 13). Appendices A and B provide more details concerning parameter estimation for the linearizable model (Section 2.2) and nonlinear model (Section 2.3), respectively.

### 2.6 Life Prediction

The fitted degradation model can be used to estimate the mean lifetime of a cell for given stress factor conditions and end-of-life (EOL) criteria. The EOL criteria will depend on the number of stress factors that are included in the life model. For the example case of a single stress factor (temperature) and a performance measure of relative resistance, the EOL criterion could be defined as a 30% increase in degradation at a temperature of \( T_0 \).
(i.e., $\mu(T_0; t) = 1.3$ at EOL). Given the linearized degradation model in Equation (3), the resulting estimated lifetime, $\hat{t}_{EOL}$, is shown in Equation (14), where $\hat{\beta}_0, \hat{\beta}_1$, and $\hat{\rho}$ are the estimated parameter values that were determined from the robust linear regression approach in Section 2.5 and Appendix A. Given the nonlinear model form in Equation (5), the resulting estimated lifetime is shown in Equation (15), where $\hat{\beta}_0, \hat{\beta}_1$, and $\hat{\rho}$ are the estimated parameter values that were determined from the robust nonlinear regression approach in Appendix B.

$$
\hat{t}_{EOL} = \exp \left\{ \log(0.3) - \left\{ \frac{\hat{\beta}_0 + \hat{\beta}_1 \cdot \frac{1}{T_0}}{\hat{\rho}} \right\} \right\} 
$$  \hspace{1em} (14)

$$
\hat{t}_{EOL} = \frac{1.3^{\frac{1}{\hat{\rho}}} - 1}{\exp \left( \hat{\beta}_0 + \hat{\beta}_1 \cdot \frac{1}{T_0} \right)} 
$$  \hspace{1em} (15)

In a more generalized case of the nonlinear model, EOL can also be estimated using a “half-the-interval” iterative method. In this approach, initial boundary conditions are set for the minimum and maximum life interval (e.g., 0 and 100 years, respectively). If the calculated mean lifetime of the cell at the midpoint of the boundary values is different from the EOL criterion ($\mu(T_0; t) = 1.3$ for relative resistance in this example), the value of the midpoint will be decreased or increased depending on whether the calculated life capability is greater than or less than the EOL criterion, respectively. This iterative process will continue until the calculated value for the mean lifetime of the cell is within a given tolerance of the EOL criterion, at which point the value of time, $\hat{t}_{EOL}$, will be reported. If the dependent variable, $\mu(T; t)$, is a naturally decreasing response instead (e.g., relative capacity and relative power), then the logic is reversed when adjusting the value of the midpoint.

### 2.7 Monte Carlo Simulations

Monte Carlo simulations based on the fitted degradation and error models, in conjunction with a variant of the parametric bootstrap procedure (Reference 14), are used to assess the uncertainty of the cell life and associated model parameters. Simulation results provide a basis for assessing the quality of the model based on “lack-of-fit” statistics (Section 2.8). Assuming that the forms of the degradation and error models are accurate, the simulations can then be used to assess the uncertainty of the mean cell life as well as the model parameters estimated from experimental data.
Using a performance measure of relative resistance as an illustration, the overall model in Equation (1) can be expanded to the form shown in Equation (16), where \( j \) represents the stress condition and \( ij \) represents the \( i^{th} \) cell within the \( j^{th} \) stress condition. \( Y_{ij}(t) \) represents the measured relative resistance of the \( ij^{th} \) cell at time \( t \) and \( \mu(X_{j};t) \) represents the expected relative resistance for cells under the \( j^{th} \) stress condition at time \( t \). \( \delta_{ij} \) represents the random proportional effect of the \( ij^{th} \) cell, and \( \pi_{ij}(t) \) represents the effect of the random measurement errors on relative resistance associated with the \( ij^{th} \) cell at the initial measurement and at time \( t \). The last term can be notionally partitioned into two terms: \( \pi_{ij}(t) \approx \lambda_{ij}(0) + \lambda_{ij}(t) \), where \( \lambda_{ij} \) represents the effect of the individual measurement errors on relative resistance at beginning of life and at time \( t \). For these simulations, the random effects, \( \delta_{ij} \), \( \lambda_{ij}(0) \), and \( \lambda_{ij}(t) \), are assumed to be independent and normally distributed each with a mean of zero and variance of \( \sigma_{\delta}^2 \), \( \alpha^2 \), and \( \alpha^2 \), respectively.

\[
Y_{ij}(t) = \mu(X_{j};t) + \delta_{ij} \cdot (\mu(X_{j};t) - 1) + \pi_{ij}(t)
\] (16)

Monte Carlo simulations should be performed with the overall test matrix that is developed using the methods provided in the Technology Life Verification Manual (Reference 5). The experimental conditions are designed to adequately assess cell chemistries for a given set of stress factors and should include the test duration, RPT frequency, number of experimental conditions, and number of cells per condition. Due to resource limitations, not every experimental condition may be verified with actual cell testing, but a sufficient subset of the overall test matrix should be conducted to adequately fit the degradation and error models using the robust regression techniques discussed in Section 2.5. The general approach for assessing the uncertainty of the life estimate is to repeatedly simulate the overall test matrix that was designed based on the TLVT approach while also matching the conditions of the actual experiment. For each independent simulation trial (representing a single realization of the complete experiment), different random realizations of cell-to-cell effects and measurement errors are added to the assumed truth provided by the degradation model that was fitted to the actual experimental data. First, the number of stress conditions that were used \( (J) \), the number of cells tested per condition \( (n_{j}: j = 1: J) \), and the times at which the cells were measured \( \{t_{k} : k = 1: K\} \) are identified. Next, the degradation model for each combination of stress condition and measurement time can be computed with \( \{\mu(X_{j};t_{k}) : (j = 1: J) \times (k = 1: K)\} \). Finally, using this setup, a number of independent trials are completed as follows:

1. Simulate \( \{\delta_{ij} : (i = 1: n_{j}) \text{with} (j = 1: J)\} \), where the \( \delta_{ij} \) are sampled independently from a normal distribution with mean zero and standard deviation, \( \sigma_{\delta} \).
2. Simulate \( \{ \lambda_{ij}(0) : (i = 1 : n_j) \} \) with \( (j = 1 : J) \), where the \( \lambda_{ij}(0) \) are sampled independently from a normal distribution with mean zero and standard deviation \( \alpha \).

3. Simulate \( \{ \lambda_{jk}(t_k) : (i = 1 : n_j) \} \) with \( (j = 1 : J) \) and \( (k = 1 : K) \), where the \( \lambda_{jk}(t_k) \) are sampled independently from a normal distribution with mean zero and standard deviation \( \alpha \).

4. Combine the constituent effects from Steps 1 through 3 to form the simulated data: \( Y_{ij}(t_k) = \mu_j(X_j(t_k)) + \delta_{ij} \cdot (\mu_j(X_j(t_k)) - 1) + \lambda_{ij}(0) + \lambda_{jk}(t_k) \) and ensure that \( Y_{ij}(t_k) > 1 \).

5. Model the collective set of simulated performance data (e.g., relative resistance) for the current trial:
   a. Estimate model parameters (degradation and error)
   b. Estimate average cell life
   c. Compute the lack of fit sum of squares (\( SS_{LOF} \)) (Section 2.8)

The summary statistics (e.g., standard deviations and order statistics) of model parameters, estimated cell life, and \( SS_{LOF} \) across trials can then be computed. The standard deviations of the model parameters and estimated cell life are referred to as bootstrap standard errors.

### 2.8 Lack-of-fit Statistic

Another important aspect of successfully estimating the mean cell life is to assess how well the degradation model fits the experimental data (i.e., the level of performance variation observed for cells aged under a common stress condition). Inaccuracies in the degradation model are detected by the lack-of-fit statistic shown in Equation (17), where \( J \) is the number of stress conditions, \( K \) is the number of RPT’s (the beginning of life RPT is denoted as RPT0), \( \overline{Y}_{j,t} \) is the average performance measure (e.g., relative resistance) of the \( j \)th stress group at RPT\( K \) corresponding to some time \( t \) (consisting of \( n_{j,t} \) cells), \( \hat{\mu}_{j,t} \) is the fitted degradation model for the \( j \)th stress group at RPT\( K \), and \( \hat{\sigma}_{j,t}^{2} \) is the fitted error model for the \( j \)th stress group at RPT\( K \), as shown in Equation (18). Note that Equation (17) is normalized by the product of the number of stress conditions and RPTs (\( J \cdot K \)) to enable a comparison across different experiments.

\[
SS_{LOF} = \frac{1}{J \cdot K} \sum_{j=1}^{J} \sum_{k=1}^{K} \frac{n_{j,t}}{\hat{\sigma}_{j,t}^{2}} \left( \overline{Y}_{j,t} - \hat{\mu}_{j,t} \right)^{2} \tag{17}
\]

\[
\hat{\sigma}_{j,t}^{2} = \hat{\sigma}_{\delta}^{2} \cdot (\hat{\mu}_{j,t} - 1)^{2} + \hat{\sigma}_{\tau}^{2} \tag{18}
\]
Monte Carlo simulations (Section 2.7) based on the developed degradation and error models are used to assess the lack-of-fit statistic. The value of $SS_{LOF}$ based on the original data is compared with the empirical distribution of the $SS_{LOF}$ values obtained from the simulation trials. An unusually large value for the lack-of-fit statistic (e.g., greater than the 95th percentile of the simulated $SS_{LOF}$ values) is indicative of model inaccuracy.

2.9 Application to Calendar Life Data

The recommended pathway for demonstrating adequate calendar life of a battery technology given a set of experimental data from typical USABC testing (References 1-4) is as follows:

1. A deterministic degradation model (Sections 2.2 and 2.3) is developed to reflect the average (i.e., typical) cell degradation over time as a function of various stress factors such as temperature and state-of-charge. This model must be accurate over the anticipated range of conditions the cells will experience. It is also assumed that the cell technology is sufficiently advanced such that, given a standard reference (e.g., 30°C), the model will predict a life capability exceeding the target requirement with some significant margin (i.e., the lower confidence bound for predicted life must exceed the 15 year goal).

2. An accurate error model (Section 2.4) is developed to reflect the cell-to-cell variability in observed degradation about the average behavior. This model accounts for variability due to measurement error as well as the intrinsic differences between cells.

3. The degradation and error models from Steps (1) and (2) are used as the basis for conducting Monte Carlo simulations (Section 2.7) to assess the lack-of-fit statistic (Section 2.8).

4. If there is no evidence for lack-of-fit, the average cell life is estimated at the lower confidence limit via the fitted degradation model. If evidence of lack-of-fit exists, the degradation model may need to be modified and this could require additional testing with extra experimental conditions.

5. Adequate calendar life of a battery technology is demonstrated if the lower confidence limit bound of the estimated cell life exceeds the requirement.
3. APPLICATION

Both the linearizable and nonlinear modeling methodologies described in Section 2.0 can be illustrated using test data acquired from high-power SAFT VL7P lithium-ion cylindrical cells (Reference 6). The primary purpose of the cell testing activities described in this section was to demonstrate the accelerated aging methodology presented in the TLVT Manual (Reference 5). Section 3.1 describes the experimental test setup for these cells. The resulting model fits of the experimental test data based on the default linearizable and nonlinear models are then presented in Sections 3.2 and 3.3, respectively.

3.1 Experimental

Experimental testing was conducted with high-power SAFT VL7P lithium-ion cylindrical cells that were rated at 7.0 Ah with a voltage range of 4.0 to 2.7 V (Reference 6). Cell aging at the Idaho National Laboratory (INL) was conducted with a Maccor series 4000 battery tester having a maximum voltage and current rating of 10 V and 12.5 A, respectively. The cells were also placed in temperature chambers that maintained ambient conditions to within ±3°C of the target during testing.

The experimental matrix is shown in Table 3.1 and consisted of 30 cells with three cells per test condition. Accelerated aging was performed at three temperatures (40, 47.5, and 55°C) and three SOCs. The SOC conditions centered on the “maximum SOC” (i.e., \( \text{SOC}_\text{MAX} \)) which was defined at 62% (Reference 6). As such, the other two SOC conditions per temperature group (i.e., \( \text{SOC}_\text{MAX} - 10\% \) and \( \text{SOC}_\text{MAX} + 10\% \)) were 52 and 72%, respectively. Only the 62% SOC condition was used for the reference temperature of 30°C. All cells were subjected to calendar-life aging at the target temperature and SOC with reference performance tests every 31.5 days.

<table>
<thead>
<tr>
<th>Group #</th>
<th>Temperature</th>
<th>State-of-Charge</th>
<th>Cells</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>30°C</td>
<td>( \text{SOC}_\text{MAX} )</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>40°C</td>
<td>( \text{SOC}_\text{MAX} - 10% )</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>40°C</td>
<td>( \text{SOC}_\text{MAX} )</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>40°C</td>
<td>( \text{SOC}_\text{MAX} + 10% )</td>
<td>3</td>
</tr>
<tr>
<td>5</td>
<td>47.5°C</td>
<td>( \text{SOC}_\text{MAX} - 10% )</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>47.5°C</td>
<td>( \text{SOC}_\text{MAX} )</td>
<td>3</td>
</tr>
<tr>
<td>7</td>
<td>47.5°C</td>
<td>( \text{SOC}_\text{MAX} + 10% )</td>
<td>3</td>
</tr>
<tr>
<td>8</td>
<td>55°C</td>
<td>( \text{SOC}_\text{MAX} - 10% )</td>
<td>3</td>
</tr>
<tr>
<td>9</td>
<td>55°C</td>
<td>( \text{SOC}_\text{MAX} )</td>
<td>3</td>
</tr>
<tr>
<td>10</td>
<td>55°C</td>
<td>( \text{SOC}_\text{MAX} + 10% )</td>
<td>3</td>
</tr>
</tbody>
</table>
The SAFT VL7P cells were first characterized with four C1/1 static capacity tests, each of which consisted of a constant current discharge at the rated value of 7.0 A to the minimum voltage from a fully charged state. This was followed by a low-current hybrid pulse power characterization (L-HPPC) test using the procedures defined in the HEV Manual (Reference 2). The final characterization test consisted of discharging the cells from a fully charged state in 5% depth-of-discharge (DOD) increments with a one hour rest in between each increment to establish the relationship between SOC and the open-circuit voltage.

Calendar-life testing consisted of resting the cells at the designated SOC (based on the corresponding open-circuit voltage) and test temperature. The cells were soaked at the target temperature for at least eight hours prior to the start of a calendar-life test to ensure thermal equilibrium. Once every 24 hours during aging, the cells were taper charged back to the target open-circuit voltage condition. Reference performance tests were conducted at 30°C and consisted of a modified L-HPPC test as defined in Reference 6. The model fits described below are based on changes in relative resistance over seven RPTs (i.e., approximately 221 days of calendar-life aging at accelerated test temperatures).

### 3.2 Linearizable Model

For the linearizable model form in Equation (2), robust linear regression (Section 2.5, Appendix A) was used to estimate the model parameters ($\hat{\beta}_0$, $\hat{\beta}_1$, and $\hat{\rho}$) using relative resistance as the performance measure. The fitted degradation model is given in Equation (19), where the resulting parameter estimates and associated standard errors are in Equation (20). These parameter estimates were based on the acquired experimental data at the elevated test temperatures (i.e., 40°C, 47.5°C, and 55°C). All of the SOC conditions at each temperature were used to estimate the model parameters since the effect between SOC$_{\text{MAX}}$, SOC$_{\text{MAX}}$ - 10%, and SOC$_{\text{MAX}}$ + 10% was not statistically distinguishable (Reference 6). From these estimates, the data clearly describe a diffusion controlled process governed by parabolic kinetics since $\hat{\rho} \approx 0.5$. Figure 1 shows the experimental test data and the corresponding linearized model fit; the temperature groups are shown in units of Kelvin (e.g., “328.0” refers to the 55°C temperature conditions, etc.). The model prediction at the reference temperature of 30°C is also included and, as shown, appears to be a good fit for the experimental data.

\[
\hat{\mu}(X;t)=1+\exp\left(\hat{\beta}_0 + \hat{\beta}_1 \cdot \frac{1}{T}\right) \cdot t^{\hat{\rho}} \tag{19}
\]

\[
\hat{\beta}_0 = 18.60 \ (1.2) \\
\hat{\beta}_1 = -6360 \ (393) \\
\hat{\rho} = 0.5285 \ (0.021) \tag{20}
\]
The error model described by Equation (8) was also fit to the experimental data at the elevated test temperatures using robust linear regression. Figure 2 shows the resulting error model fit and the estimated parameters are shown in Equation (21). From these estimates, it can be inferred that the cell-specific proportional effect has a standard deviation of about 0.06 while the measurement error has a relative standard deviation of about 0.01. Although this implies that the linearizable degradation model matches relatively well with the experimental data, significant lack-of-fit was detected using the methodology described in Section 2.8. The value of $SS_{LOF}$ from Equation (17) based on the experimental data was 1.5158. This result exceeded the 97th percentile of $SS_{LOF}$ values obtained with the simulation trials, which is indicative of model inaccuracy. The lack of fit can be observed, for example, in Figure 1 at the highest temperature (55ºC) where the model tends to under-predict the observed resistance gain at two months while over-predicting the observed resistance gain at six months.

**Figure 1.** Fitted linearized model versus experimental data
\[ \hat{\sigma}_\phi^2 = 2.5 \times 10^{-3} \]
\[ \hat{\alpha}^2 = 1.3 \times 10^{-4} \]  

Figure 2. Fitted error model for linearizable case

Nevertheless, despite the evidence for lack-of-fit, the fitted degradation model can be used to estimate the mean lifetime of the cells to demonstrate the approach described in Section 2.6. Assuming the EOL criterion is defined to be a 30% increase in relative resistance at the reference temperature of 30°C, the resulting life prediction is shown in Equation (22), where the value of temperature is in units of Kelvin (i.e., 303 K). Using the model parameter estimates in Equation (20), the estimated mean lifetime of the cells is \( \hat{t}_{\text{EOL}} = 9.4 \) years. The bootstrap methodology (Reference 14) can then be used to assess the statistical uncertainty in the predicted lifetime. Figure 3 shows results of 1000 bootstrap simulations for the VL7P experimental cell data based on the linearized degradation model (Reference 6). Figure 4 provides a graphical representation of the resulting weighted average for the mean cell lifetime capability at the reference temperature of 30°C with the corresponding upper and lower confidence levels. The 95%
The lower confidence level is 7.9 years since 950 of the 1000 simulation results exceeded that life estimate. The 95% upper confidence level is 12.5 years since the predicted mean life for 50 of the 1000 simulations results showed higher estimates. The combination of the 95% upper and lower confidence limits results in an overall 90% confidence interval between 7.9 and 12.5 years of life. These confidence levels are consistent with the estimated mean lifetime of 9.4 years using the model parameter values. The weighted average of 9.8 years is based on the bootstrap simulations of the experimental data and should be reasonably close to the estimated mean lifetime.

\[
\hat{t}_{EOL} = \exp \left\{ \log(0.3) - \left( \hat{\beta}_0 + \hat{\beta}/303 \right) / \hat{\rho} \right\} = 9.4 \text{ yrs}
\]  

Figure 3. Histogram of simulated life capability using 1000 bootstrap trials for the linearizable model

Figure 4. Estimate mean cell life capability with statistical confidence levels for the linearizable model.
3.3 Nonlinear Model

For the nonlinear model form in Equation (5), robust nonlinear regression (Section 2.5, Appendix B) was used to estimate the model parameters ($\beta_0$, $\beta_1$, and $\rho$) using relative resistance as the performance parameter. The fitted degradation model is given in Equation (23), where the resulting parameter estimates and associated standard errors are in Equation (24). As with the linear model fit, these parameter estimates were based on the acquired experimental data at the elevated test temperatures (i.e., 40°C, 47.5°C, and 55°C) and all three of the SOC conditions. Figure 5 shows the experimental test data and corresponding nonlinear model fit. The model prediction at the reference temperature of 30°C is also included and, as shown, appears to be a good fit for the experimental data.

Figure 5. Fitted nonlinear model versus experimental data
\[
\mu(T; t) = \left( 1 + \exp \left( \hat{\beta}_0 + \frac{\hat{\beta}_1}{T} \cdot t \right) \right)^ho
\]  
\hspace{1cm} (23)

\[
\hat{\beta}_0 = 41.17 \ (2.4)
\]

\[
\hat{\beta}_1 = -1.229 \times 10^4 \ (757)
\]  
\hspace{1cm} (24)

\[
\hat{\rho} = 0.0821 \ (0.0041)
\]

The error assessment for the nonlinear model follows the same approach as the linearizable case, where Equation (8) is used to fit the experimental data at the elevated test temperatures using robust linear regression. Figure 6 shows the resulting error model fit and the estimated parameters are shown in Equation (25). As with the linearizable case, the cell-specific proportional effect has a standard deviation of about 0.06 while the measurement error has a relative standard deviation of about 0.01. However, there was no evidence of lack-of-fit for the nonlinear model, with an \( SS_{LOF} \) value of 0.509, as determined from Equation (17). This value was exceeded by more than the 90% of the \( SS_{LOF} \) values obtained \( via \) the simulation trials.

\[
\hat{\sigma}_\delta^2 = 2.9 \times 10^{-3}
\]

\[
\hat{\lambda}^2 = 1.3 \times 10^{-4}
\]  
\hspace{1cm} (25)

The closer fit is not surprising given the additional flexibility of the nonlinear model. However, one of the negative tradeoffs associated with the nonlinear approach is the additional computational expense required (mainly associated with the simulations), especially in the cases where the initial guesses for the parameter values are not reasonably close to the final estimate. Additionally, interpretation of the nonlinear model can be somewhat more difficult and should typically require a physical basis for its development.
The calculated mean cell lifetime (Section 2.6), assuming an EOL criterion of 30% increase in relative resistance at $T_o = 30^\circ C$ (i.e., 303 K), is shown in Equation (26). Given the model parameter values in Equation (24), the estimated cell life capability is $\hat{\tau}_{EOL} = 12.9$ years. Figure 7 shows the histogram resulting from the 1000 bootstrap simulations based on the nonlinear degradation model and Figure 8 provides a graphical representation of the corresponding statistical confidence window. The 95% lower confidence level is 10.1 years since 950 of the 1000 simulation results exceeded that life estimate. The 95% upper confidence level is 17.0 years since the predicted mean life for 50 of the 1000 simulations results showed higher estimates. These confidence levels are consistent with the estimated mean lifetime of 12.9 years based on the model parameter estimates. The weighted average using the 1000 bootstrap simulations is 13.1 years.

\[
\hat{\tau}_{EOL} = \frac{1.3^{\frac{\hat{\gamma}}{303}} - 1}{\exp\left(\hat{\beta}_0 + \hat{\beta}_1 \frac{1}{303}\right)} = 12.9 \text{ yrs}
\]  

\hspace{1cm} (26)
Figure 7. Histogram of simulated life capability using 1000 bootstrap trials for the nonlinear model

- Life estimate at 95% LCL = 10.1 years
- Life estimate at 95% UCL = 17.0 years
- Weighted average = 13.1 years

TEMP: 303 K

Figure 8. Estimate mean cell life capability with statistical confidence levels for the nonlinear model
4. RATE-BASED DEGRADATION MODELING

4.1 Methodology

The change in cell performance over time is typically expressed in terms of a cumulative degradation model that is formulated in terms of exposure to a constant stress (see Sections 2 and 3) and the models are generally used to predict degradation in well-controlled conditions. However, another critical component of successful battery life estimation is a model that can account for cell aging under non-steady state conditions. In automotive (and other) applications, for example, cells are usually deployed in non-isothermal environments. Thus, in these cases it may be more useful to consider a different modeling framework based on the instantaneous degradation rate of a cell rather than cumulative level of degradation. Due to their form, such models naturally facilitate the prediction of the cumulative degradation in non-isothermal conditions (Reference 7).

Rate-based models can come in various forms and have an empirical, semi-empirical, or physical basis (an example model with a physical basis is provided below). If the degradation behavior is memoryless (i.e., path independent), then the instantaneous degradation rate at a point in time will depend only on the present level of the degradation state and the present stress that is applied to the cell. If the degradation has a memory effect (i.e., path dependent), then the details of the stressing history must also be considered in the model. Path dependent experimental test data require a physical basis in the rate-based model to properly account for the mechanistic changes that have occurred in the cell chemistry. Memory effects could come from various conditions such as periodic off-normal testing (e.g., at low temperatures) or by the onset of cell failure mechanisms (e.g., an internal soft short).

A generalized rate-based empirical model form for of a path independent, or memoryless, degradation is shown in Equation (27), where $\mu$ is the performance measure (i.e., relative resistance in the example case) and temperature, $T$, is the sole stress factor. The cumulative degradation over the temperature profile $T[0, t]$ is represented by Equation (28). The model parameters, $\alpha_1, \alpha_2, \ldots, \alpha_p$, must be estimated from cell experimental data that are accumulated from the RPTs as a function of aging.

$$\frac{d\mu}{dt} = g(\mu, T(t))$$  \hspace{1cm} (27)

$$\mu(T[0, t]) = \int_0^t g(\mu(\tau), T(\tau), \alpha_1, \alpha_2, \ldots, \alpha_p) d\tau$$  \hspace{1cm} (28)

To illustrate, let $Y_{ij}$ be the $j$th measurement of the $i$th cell (for $i = 1:N$ and $j = 1:n_i$), $t_{ij}$ be the time at which $Y_{ij}$ was acquired, and $T[0, t_{ij}]$ be the temperature profile experienced by the $i$th cell through $t_{ij}$. The collection of data can then be compactly expressed by Equation (29). Given estimates for the model parameters ($\hat{\alpha}_1, \hat{\alpha}_2, \ldots, \hat{\alpha}_p$), the predicted value of each observation (e.g., $i$th cell through $t_{ij}$) can be obtained by numerically
integrating the derivative function in Equation (30) over the temperature path as expressed in Equation (31). The process for the numerical integration of the derivative function is provided in Table 4.1. Model parameter estimates will likely involve nonlinear regression and will need to compute \( \hat{p}_j \) (for all \( i \) and \( j \)) repeatedly to find the \( \hat{\alpha}_i \) that minimizes some objective function that is expressed in terms of the differences between \( \hat{Y}_{ij} \) and \( Y_{ij} \).

\[
\begin{align*}
\{Y_{11} \mid t_{11}, T[0, t_{11}]=[t_{11}, t_{11}]\}, \{Y_{12} \mid t_{12}, T[0, t_{12}]=[t_{12}, t_{12}]\}, \ldots, \{Y_{in} \mid t_{in}, T[0, t_{in}]=[t_{in}, t_{in}]\}
\{Y_{21} \mid t_{21}, T[0, t_{21}]=[t_{21}, t_{21}]\}, \{Y_{22} \mid t_{22}, T[0, t_{22}]=[t_{22}, t_{22}]\}, \ldots, \{Y_{2n} \mid t_{2n}, T[0, t_{2n}]=[t_{2n}, t_{2n}]\}
\ldots
\{Y_{i1} \mid t_{i1}, T[0, t_{i1}]=[t_{i1}, t_{i1}]\}, \{Y_{i2} \mid t_{i2}, T[0, t_{i2}]=[t_{i2}, t_{i2}]\}, \ldots, \{Y_{in} \mid t_{in}, T[0, t_{in}]=[t_{in}, t_{in}]\}
\ldots
\{Y_{N1} \mid t_{N1}, T[0, t_{N1}]=[t_{N1}, t_{N1}]\}, \{Y_{N2} \mid t_{N2}, T[0, t_{N2}]=[t_{N2}, t_{N2}]\}, \ldots, \{Y_{Nm} \mid t_{Nm}, T[0, t_{Nm}]=[t_{Nm}, t_{Nm}]\}
\end{align*}
\]

(29)

\[
\frac{d\mu}{dt} = g(\mu(t), T(t), \hat{\alpha}_1, \hat{\alpha}_2, \ldots, \hat{\alpha}_p)
\]

(30)

\[
\hat{Y}_{ij} = \int_0^{t_{ij}} g(\hat{Y}(T[0, \tau]), T(\tau) \mid \hat{\alpha}_1, \hat{\alpha}_2, \ldots, \hat{\alpha}_p) d\tau
\]

(31)

**Table 4.1. Integrating the derivative function numerically**

<table>
<thead>
<tr>
<th>( \delta = \frac{t}{\Delta t} )</th>
<th>( T(\delta) )</th>
<th>( \hat{Y}(\delta) )</th>
<th>( \frac{d\hat{Y}(\delta)}{dt} )</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>( T(0) )</td>
<td>( \hat{Y}(0) )</td>
<td>( g(\hat{Y}(0), T(0)) )</td>
</tr>
<tr>
<td>1</td>
<td>( T(1) )</td>
<td>( \hat{Y}(0) + \frac{d\hat{Y}(0)}{dt} \cdot \Delta t )</td>
<td>( g(\hat{Y}(1), T(1)) )</td>
</tr>
<tr>
<td>2</td>
<td>( T(2) )</td>
<td>( \hat{Y}(1) + \frac{d\hat{Y}(1)}{dt} \cdot \Delta t )</td>
<td>( g(\hat{Y}(2), T(2)) )</td>
</tr>
<tr>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>( m = \frac{t_{ij}}{\Delta t} )</td>
<td>( T(m) )</td>
<td>( \hat{Y}(m-1) + \frac{d\hat{Y}(m-1)}{dt} \cdot \Delta t )</td>
<td>( g(\hat{Y}(m), T(m)) )</td>
</tr>
</tbody>
</table>
4.2 Application: Non-Isothermal Aging

The purpose of the cell testing activities described in this section was to assess the memory effects (if any) of lithium-ion cells that are aged at varying temperatures. Rate-based modeling tools were used to develop a degradation model and predict life capability with the bootstrap approach (Reference 14). Cell testing was performed at both the Idaho and Argonne National Laboratories (INL and ANL, respectively). This study represents one of the path dependence studies recommended by the Technology Life Verification Test (TLVT) Manual (Reference 5). Other path dependence studies can include intermixing calendar and cycle-life aging protocols or varying SOC conditions. Additionally, interaction between these various path dependence studies could be investigated as well.

4.2.1 Experimental

Cell testing was conducted with commercially available, high-power Sanyo SA lithium-ion cells, which consist of a Li(Mn, Co, Ni)O2 + Li-Mn-O spinel cathode and a graphite anode (Reference 17). They are 18650-size (i.e., 18 mm diameter and 65 mm length), with a rated capacity of 1.2 Ah and a voltage range of 4.2 to 2.7 V. Cell aging at INL was conducted with a Maccor series 4000 battery tester having a maximum voltage and current rating of 10 V and 12.5 A, respectively. The cells were placed in Tenney Junior temperature chambers that maintained ambient conditions to within ±3°C of the target during testing. Cell aging at ANL was conducted with an Arbin tester having a maximum voltage and current rating of 10 V and 25 A, respectively. The cells at ANL were also placed in Tenney Junior temperature chambers.

The test matrix is shown in Table 4.2 and consisted of 24 cells with three cells per test condition. Both INL and ANL had control groups (i.e. isothermal conditions) at 45 and 55°C to establish the baseline performance at each temperature. The first non-isothermal group (“Switch”) consisted of calendar-life aging at 55°C until the power fade reached at least 15% and then switching to 45°C for the remaining calendar aging (ANL performed the same test, but with the temperatures reversed). The other non-isothermal group (“Pulse”) consisted of switching between 55 and 45°C during calendar life aging after each RPT. All cells were subjected to calendar-life aging at 60% SOC (3.89 V) with reference performance tests every 32 days.

The Sanyo SA cells were first characterized with three C1/1 static capacity tests (i.e., a constant current discharge at the rated value of 1.2 A to the minimum voltage from a fully charged state). This was followed by a constant power discharge at a scaled, 10-kW level; given a sizing factor of 1400 for these cells (Reference 17), the applied constant power level was 7.14 W. Next, a low-current hybrid pulse power characterization test (L-HPPC) was performed using the procedures defined in the PHEV Manual (Reference 1). The final characterization tests included a C1/25 static capacity test (i.e., a full discharge and charge at 1/25th of the rated current, 1.2 A / 25 = 48 mA) and an AC impedance sweep at 60% SOC over a frequency range of 100 kHz to 10 mHz with ten points per decade of frequency.
Table 4.2. Sanyo SA cell test matrix for memory study

<table>
<thead>
<tr>
<th>Lab</th>
<th>Group #</th>
<th>Type</th>
<th>Label</th>
<th>Cells</th>
<th>Temp. (°C)</th>
</tr>
</thead>
<tbody>
<tr>
<td>INL</td>
<td>1</td>
<td>ISO-LO</td>
<td>Control</td>
<td>3</td>
<td>45</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>ISO-HI</td>
<td>Control</td>
<td>3</td>
<td>55</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>NON-ISO</td>
<td>Switch</td>
<td>3</td>
<td>55 → 45</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>NON-ISO</td>
<td>Pulse</td>
<td>3</td>
<td>55 / 45</td>
</tr>
<tr>
<td>ANL</td>
<td>5</td>
<td>ISO-LO</td>
<td>Control</td>
<td>3</td>
<td>45</td>
</tr>
<tr>
<td></td>
<td>6</td>
<td>ISO-HI</td>
<td>Control</td>
<td>3</td>
<td>55</td>
</tr>
<tr>
<td></td>
<td>7</td>
<td>NON-ISO</td>
<td>Switch</td>
<td>3</td>
<td>45 → 55</td>
</tr>
<tr>
<td></td>
<td>8</td>
<td>NON-ISO</td>
<td>Pulse</td>
<td>3</td>
<td>45 / 55</td>
</tr>
</tbody>
</table>

Calendar-life testing consisted of resting the cells at an open circuit voltage condition at the designated test temperature provided in Table 4.2. A pulse-per-day was also performed on the cells using the profile shown in Figure 9 (Reference 1). This profile consists of the standard L-HPPC pulse profile (with a slightly longer rest step) followed by a 300-s voltage clamp pulse where the cells brought back to the designated voltage corresponding to 60% SOC. The cells were soaked at the target test temperature for at least 4 hours prior to the start of each calendar-life test to ensure thermal equilibrium. Reference performance tests were conducted at 30°C every 32 days during aging. The RPTs consisted of a scaled, 10-kW constant power discharge, L-HPPC, and an AC impedance sweep at 60% SOC over a frequency range of 100 kHz to 10 mHz.

Figure 9. Calendar-life pulse-per-day profile (Reference 1)
4.2.2 Results

This section provides preliminary rate-based modeling approaches for relative resistance using a selected subset of the experimental data (i.e., the INL cell groups) and illustrates the overall methodology for life estimation. A simple rate-based model form is shown in Equation (32). Using numerical integration and nonlinear regression, the model parameter fits to the experimental data are provided in Equation (33). Figure 10 shows the test data and corresponding model fits. Overall, the rate-based model matches the data reasonably well. The Sanyo SA cells have completed six RPTs and the “Switch” group that was initially aged at 55°C surpassed 15% power fade after the third RPT.

\[
\frac{d\mu}{dt} = \exp\left\{ \beta_0 + \beta_1 \frac{1}{T} \right\}
\]  

(32)

\[
\hat{\beta}_0 = 31.68 \ (1.2) \\
\hat{\beta}_1 = -10383 \ (380)
\]  

(33)

![Figure 10. Simple rate-based model fit to the INL experimental data](image)

Estimates of the error model parameters from Equation (8) above are provided in Equation (34). From these estimates, both the cell-specific proportional effect and measurement error have relative standard deviations of about 0.01. Although this seems to indicate a reasonable fit, a moderate level of lack-of-fit was indicated using the statistical analysis presented in Section 2.8. The value of $SS_{LOF}$ from Equation (17)
using the experimental data was 2.6, which exceeded the 98th percentile of $SS_{LOF}$ values obtained from the simulation trials. The lack of fit can be observed in Figure 10, where the model tends to under-predict the observed resistance gain beyond 0.4 years at 55°C.

$$\hat{\sigma}^2 = 8.9 \times 10^{-5}$$
$$\hat{\alpha}^2 = 6.5 \times 10^{-5}$$

A more generalized form of the rate-based model (Reference 7) is shown in Equation (35), where $k(T)$ is defined in Equation (36). The physical basis for this model is analogous to the high-temperature oxidation of metals, such as niobium and cerium (References 15 and 16), where there were significant changes in the diffusion rate at which the materials react at different times due to structural changes in the oxide scale. Using this mechanism in lithium-ion cells, the products that form in the solid electrolyte interphase (SEI) layer may structurally change with time as the reaction proceeds. The resulting fitted model parameter values based on numerical integration and nonlinear regression are provided in Equation (37) and Figure 11 shows that the 55°C data now more accurately matches the model compared to the simpler model in Figure 10. A negative value for $\hat{\rho}$ indicates that the rate of degradation increases with age. Estimates of the error model parameters are provided in Equation (38), where both the cell-specific proportional effect and measurement error have relative standard deviations of about 0.01. However, there is still some evidence for lack-of-fit since the calculated value for $SS_{LOF}$ was 2.15, which exceeded the 96th percentile of $SS_{LOF}$ values obtained from the simulation trials.

$$\frac{d\mu}{dt} = k(T) \cdot \mu^{-\rho}$$

$$k(T) = \frac{\exp \left( \beta_0 + \beta_1 / T \right)}{(\rho + 1)}$$

$$\hat{\beta}_0 = 29.83 \ (1.2)$$
$$\hat{\beta}_1 = -9980 \ (360)$$
$$\hat{\rho} = -0.421 \ (0.125)$$

$$\hat{\sigma}^2 = 9.4 \times 10^{-5}$$
$$\hat{\alpha}^2 = 1.3 \times 10^{-4}$$

The 2010 hourly ambient temperature profile from Phoenix, AZ is used to illustrate life estimations under non-isothermal conditions based on the rate-based approach (Reference 7). Figure 12 shows the year-long temperature profile. From the generalized form of the fitted model in Equation (35) and parameter estimates in Equation (37), the predicted increase in relative resistance assuming repeated instances of this temperature profile (beginning on January 1) is provided in Figure 13. The resulting mean cell life (i.e.,
when the relative resistance first exceeds 1.3), is estimated to be about 4.5 years. Figure 14 shows the empirical cumulative distribution function of end-of-life values obtained from the bootstrap simulation. These data indicate that the 95% upper and lower confidence bound for the mean lifetime of the cells is 4.75 and 3.7 years, respectively.

Figure 11. Generalized rate-based model fit to the INL experimental data

Figure 12. Hourly temperature profile: Phoenix, AZ, Calendar year 2010
Figure 13. Predicted rise in relative resistance

Figure 14. Cumulative distribution function of predicted mean life from bootstrap
5. BATTERY LIFE ESTIMATION SOFTWARE

The purpose of the BLE software package (http://www.anl.gov/techtransfer/Software_Shop/TLVT/TLVT.html) is to facilitate the analysis of simulated and experimental test data. The software captures all of the mathematical analysis and life-simulation tools described in this manual as well as the default degradation and error models described in Section 2. This section provides a description of the software contents and a user’s guide to running the application.

5.1 System Requirements

The minimum system requirements for the BLE software package are a PC computer with a Pentium 4 processor with at least 1 GB of memory and VGA graphics. There should also be a minimum of 3 MB of free space on the hard disk.

The software has been extensively tested on Windows XP and on Windows 7. The Microsoft .NET framework version 4 Client Profile must be installed for the software to operate. The minimum system requirement for the .NET 4 is Windows XP SP3. It will operate with the other .NET 4.0 profiles. To download and install the .NET Framework 4.0, go to the following website and click on "DOWNLOAD." The program will also function if you install the full .NET Framework 4 instead.


5.2 Battery Life User Interface

The BLE software application is designed to be very user-friendly. All functions are accessible through menus and data-entry forms. When the application starts, the blank desktop, shown in Figure 15 will appear. The main menu consists of five choices: File, Edit, Run, View and Help. A detailed description of these menu choices are provided in Section 5.5.

Figure 15. A screen view of the “Battery Life Estimation” desktop
5.3 Equation Requirements

The data to be fit or modeled must at least be time-based (i.e., time is an independent variable); other variables, such as temperature and energy could also be included. A maximum of 100 variables can be used in the model equation.

The model equation can be linearizable, as described in Section 2.2. For this approach, the degradation model must be re-expressed with linear transformations, where each transform consists of only one independent variable. Consequently, the number of transform equations for the linearized form is based on the number of independent variables in the model equation. For example, the expression \( R = A + B/T + Ct \) with \( A, B, \) and \( C \) as the fitting coefficients has the linear transform equations of \( R, 1/T, \) and \( t \).

A more complex expression such as \( R = A \exp(B/T)\tau \) can be linearized to \( \ln R = \ln A + B/T + z \ln(\tau) \), but it is not in the proper form because of the \( \ln A \) term (log of a constant). The original expression should be rewritten as \( R = \exp(A' + B/T)\tau \), then linearized with \( \ln R = A' + B/T + z \ln(\tau) \) with transform equations of \( \ln R, 1/T, \) and \( \ln(\tau) \).

The model equation can also be nonlinear, as described in Section 2.3. Nonlinearizable model equations, such as \( R = [1 + \exp(A' + B/T)\tau]^{1/2} \), do not require transformations, but initial guesses for the model parameters must be provided to the software for the regression analysis. These equations can be as complex as needed, but overly-complex equations will not work (see below).

5.4 Data Formatting Requirements

It is assumed that the data to be fitted are arranged in columns (e.g., in EXCEL or plain text) with a comma as the delimiter in plain-text files. A header row at the top of each column must be included as well. The columns do not have to be sequential. It is further assumed that all data to be fit or modeled are time-based and that time is included as one of the columns in the discrete variable input file.

The data to be fit should be normalized to the \( t = 0 \) value for each dependent variable of the degradation model (Sections 2.2 and 2.3). However, the beginning of life value (i.e., at \( t = 0 \)) should not be included in the BLE software data file. If it is not removed, the program will filter these values out as well as any dependent variable values that are less than zero.

Table 5.1 shows part of a sample input file arranged in columns with time, temperature, and relative resistance. Note that if there are missing measurements, as shown in the second row of data, they must be removed before starting the analysis and simulation program. If they are not removed, an error message will be displayed, stating that there are no data available.
Table 5.1. Example of data containing a missing measurement

<table>
<thead>
<tr>
<th>Time, yr</th>
<th>Temperature, K</th>
<th>Relative Resistance</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.1</td>
<td>298</td>
<td>1.02</td>
</tr>
<tr>
<td>0.1</td>
<td>298</td>
<td></td>
</tr>
<tr>
<td>0.1</td>
<td>298</td>
<td>1.01</td>
</tr>
<tr>
<td>0.1</td>
<td>308</td>
<td>1.03</td>
</tr>
</tbody>
</table>

5.5 Software Navigation

This software navigation section details all of the functions of the BLE software tool. In the accompanying description, the "►" symbol indicates a sequence of mouse clicks.

5.5.1 File Menu

The File menu is shown in Figure 16 and consists of the following choices: New, Open, Save, Save As, Preview Report, Print Report, Exit and Recent files.

File ► New ► Fit. This option activates the Fit Wizard (Section 5.6.3) and allows the user to start a new fit based on a modeling equation and an existing set of data (i.e., from a file).

File ► New ► Simulation. This option activates the Simulation Wizard (Section 5.6.4) and allows the user to start a new Monte Carlo simulation based on a modeling equation.
**File ➤ Open (Ctrl+O).** This option opens an existing *.Life file. The files contain the information needed to carry out the fit or simulation or a combination of the two. If the application finds that there is an error in the file, such as it was created by an earlier version of the software or is corrupt, the application will display an error. (Section 5.6.1)

**File ➤ Save (Ctrl+S).** This option saves the existing fit / simulation information for later use. The file is saved to the current filename or to a file called "default.Life."

**File ➤ Save As.** This option saves the current fit / simulation information for later use. The file is saved to a user-defined filename.

**File ➤ Preview Report.** This option lets the user see the report on the desktop before committing it to paper (Section 5.7).

**File ➤ Print Report (Ctrl+P).** This option lets the user commit the fit / simulation calculations to paper.

**File ➤ Exit (Ctrl+Shift+X).** This option ends the current session.

**File ➤ Recent files.** This option displays the five most-recent files used or created. The menu item will not be shown until file(s) have been saved or read. Clicking on a file name in the list will open the file for use.

### 5.5.2 Edit Menu

The Edit Menu is shown in Figure 17 and consists of the following choices: Equations, Life confidence limit, and Copy view to clipboard.

![Edit menu](image)

**Figure 17.** Edit menu

**Edit ➤ Equations (Ctrl+E).** This option starts the equation editor to alter the stored equations that are used in the current fit and/or simulation (Section 5.6.3.3).

**Edit ➤ Life confidence limit (Ctrl+L).** This option changes the lower and/or upper confidence limits that are used for the life projections (Section 5.6.2.4).
Edit ▶ Copy view to clipboard (Ctrl+C). This option copies the contents of the current (foremost) view to the Windows clipboard for pasting into other clipboard-aware applications, such as EXCEL or Word. It is copied as a windows metafile if the view contains a plot, or as HTML if the view contains text and/or data tables. Data table displays are copied exactly as they appear on the screen.

5.5.3 Run Menu

The Run Menu is shown in Figure 18 and consists of the following choices: Fit and Simulation.

Run ▶ Fit (Ctrl+F). This option re-runs the present fit.

Run ▶ Simulation (Ctrl+Shift+S). This option displays the sub-menu.

Run ▶ Simulation ▶ Perform Simulation. This option re-runs the current simulation.

Run ▶ Simulation ▶ Another Life Estimate. This option allows another life estimate to be calculated from the current simulation results.

5.5.4 View Menu

The View menu is shown in Figure 19 and consists of the following choices: Results of Models, Plot..., and Data....
5.5.4.1 Results of Models

The sub-menu for model results is also shown in Figure 19 and consists of the following choices: Fitting, and Monte Carlo simulation.

View ▶ Results of Models ▶ Fitting (Ctrl+Shift+G). This option displays the results of the fitting calculations, and includes the model equation, the names and variables used, the values of the fitting parameters, the estimate of errors, and lack of fit information (Section 5.7.1).

View ▶ Results of Models ▶ Monte Carlo simulation (Ctrl+S). This option displays the results of the Monte Carlo simulation (Section 5.7.2).

5.5.4.2 Plot

The plot sub-menu is shown in Figure 20 and has five choices: Fitting Results, Var(Y) vs. (\(\hat{\mu} - 1\))^2, (\(Y - \hat{\mu}\)) vs. \(\hat{\mu}\), \(\hat{\mu}\) vs. \(Y\), and Monte Carlo simulation (Section 5.7.2.2).

![Figure 20. View menu and plot sub-menu](image)

View ▶ Plot... ▶ Fitting Results (Ctrl+Shift+N). This option produces a plot of the experimental data and the fit.

View ▶ Plot... ▶ Var(Y) vs. (\(\hat{\mu} - 1\))^2 (Ctrl+Shift+V). This option produces a plot of the error model results.

View ▶ Plot... ▶ (\(Y - \hat{\mu}\)) vs. \(\hat{\mu}\). This option produces a plot of the difference between the average, relative value and the fitted value.

View ▶ Plot... ▶ \(\hat{\mu}\) vs. \(Y\). This option produces a plot of the fitted value versus the average, relative value.

View ▶ Plot... ▶ Monte Carlo simulation (Ctrl+Shift+T). This option produces a cell-distribution bar chart.
5.5.4.3 Data

The data sub-menu is shown in Figure 21 and has two choices: Input data and model. The model sub-menu is also shown in Figure 21 and has three choices: Dependent variable, Var(Y), and Monte Carlo simulation. The label of the dependent variable menu item will reflect the fitted response (i.e., the dependent variable, such as resistance, capacity, etc.).

View ► Data ► Input Data. This option displays the input data, and is useful for comparing the known input data to what the software read from the input file. Figure 22 shows a sample data display with the proper format discussed in Section 5.4. The data can also be sorted in ascending or descending order by simply clicking on the column title. When the data are sorted by a particular column, a small arrow (▲ or ▼) will appear that indicates the direction of the sort. The data displayed in the grid can be exported to a comma-separated values (CSV) file by clicking on the "Export>>" button on the right hand side, as shown in Figure 22.

View ► Data ► Model... ► Rel. Resistance. This option displays the degradation parameter data; in this case, it is the relative resistance. The label will automatically adjust to the appropriate parameter being fit or modeled by the software.

View ► Data ► Model... ► Var(Y). This option displays the variance of the output data.

View ► Data ► Model... ► Monte Carlo simulation. This option displays the results from the Monte Carlo simulation, including the parameter fits, error variances (i.e., SIGMA_D is the variance of cell-to-cell effects and SIGMA_E is the variance of the measurement error), life projections, and the lack-of-fit sum of squares values generated for each simulation trial. A sample Monte Carlo simulation output is shown in Figure 23. The data displayed in the grid can be exported to a CSV file by clicking on the "Export>>" button on the right hand side.
5.5.5 Help Menu

The main help screen is shown in Figure 24 and provides a detailed description of the program’s capability and navigation.
5.6 Using the Software

5.6.1 Creating or Opening an Existing Fit/Simulation File

Creating a new fit or simulation (File ➤ New ➤) will immediately launch the appropriate fit wizard (Section 5.6.3) or simulation wizard (Section 5.6.4). When opening an existing file (File ➤ Open), the user will be prompted with a file-selection dialog box, similar to that shown below in Figure 25. The BLE software files are saved with a “*.Life” extension and contains information regarding what type of operation is to be done (fit, simulation or both) and the values of other parameters used in the program.
5.6.2 Fitting and Simulation

Once a file has been opened or created, there are three options available in this software package for fitting and/or simulating the data:

1. **Fit Only.** This option solves for parameter values based on input data and the model equation.

2. **Fit and Simulate.** This option solves for parameter values and simulates life based on those fitted values.

3. **Simulate Only.** This option simulates life based on user-provided parameter values with the assumption that the fit was completed independent of this software package.

5.6.2.1 *Fit Only*

The program will request the user to identify the stress factor groups within the dataset to include in the fitting process. A sample dialog box is shown in Figure 26, with temperature (in Kelvin) identified as the stress factor of interest. The user may select/unselect the datasets indicated by the experimental stress condition(s) by clicking on the check boxes or on the Select All or Unselect All buttons. Click **OK** to proceed to the fitting process. The results of the fit can then be seen by clicking on the View menu choices (Section 5.5.4).
5.6.2.2 Fit and Simulation

The program first proceeds through the Fit Only function described in Section 5.6.2.1 above, and then prompts the user to run the simulation. The dialog then becomes similar to that found in the Fit Wizard discussion (Section 5.6.3), followed by the Simulation Wizard (Section 5.6.4). The results of the fit and simulation can be seen by clicking on the View menu choices (Section 5.5.4).

5.6.2.3 Simulation only

The dialog is very similar to the Fit and Simulation description in Section 5.6.2.2 above, except that no fitting is performed and must be provided by the user. The results of the simulation can then be seen by clicking on the View menu choices (Section 5.5.4).

5.6.2.4 Life Confidence Limits

There are two types of life projections that can be performed with this program, one based on experimental data (Section 5.6.2.2) and the other based on hypothetical data simulated from the life equations (Section 5.6.2.3). The difference between the two types of projections is in how they use confidence limits. The projection based on experimental data uses an upper confidence limit (UCL) and a lower confidence limit (LCL); the one based on simulations just uses the lower confidence limit. A typical display to change just the lower confidence limit is shown in Figure 27. The life projection will then be calculated using the input value(s), then displayed on subsequent dialogue boxes and reports.
5.6.3 Fit Wizard

The Fit Wizard assumes that time is an independent variable for all modeling equations. The fitting process is as follows:

1. Specify the data to be fit
2. Associate variables to the data parameters
3. Specify the life equation and the corresponding transforms using the identified variables
4. Import test data from file
5. Identify stress factor combination(s) to include in the fit
6. Perform the fit

With each dialog box in the Fit Wizard, the user can move forward by clicking the “Next” button. If not all of the entries were appropriately filled, the software will prompt the user for the missing information. To update or modify a previous entry, press the “Back” button to return to the previous screen.

5.6.3.1 Defining the Data

The first step in the fitting process is to define the type of data that are used for the fit. Figure 28 shows the list of available dependent and independent variables in the software tool. The dependent variables include resistance, capacity, energy, and power, and only one can be selected per fit. The independent variables include time, temperature, state-of-charge (SOC), power, energy, capacity, discharge cutoff, and charge cutoff. More than one independent variable can be chosen per fit, and they can be selected by clicking on the variable name. For example, a total of three variables (one dependent, and two independent) have been identified for the fit in Figure 28. If a variable name other than
those shown in Figure 28 is to be used, click on the "User defined..." button. This option allows any variable name to be used in the application.

![Figure 28. Typical display to define the data in a file](image)

### 5.6.3.2 Associate Variables with the Definitions

Once the data have been defined, the next step is to assign variables to the parameters. Since there are three parameters identified in the example shown in Figure 28, the software will prompt the user to identify three algebraic variables, as shown in Figure 29. The algebraic variables can be more than one letter and the names are not case-sensitive (e.g., “t” for time and “T” for temperature will not work). The first variable name in the list is the dependent variable (e.g., resistance).

All temperatures in the fitting and simulation processes must be in Kelvin. If the data input already has temperature in Kelvin, put a “k” in the “Temperature: Celsius/ Kelvin” text box. Otherwise, place a “c” in the text box, and the software will automatically perform the conversion to Kelvin.

The type of model to be used is also indicated on this dialog box. If the model is linearizable, click on the "Linear" radio button; otherwise click on the "Nonlinear" radio
button. It should be noted that these choices are mutually exclusive. Both cannot be selected at once.

The software will not associate any physical process with the name and, hence, does not implicitly know if the dependent variable increases or decreases with time. The "Increases with time" box to the right of the dependent variable text box should be checked if the dependent variable does increase with time (e.g., it is checked in the case of resistance) or unchecked if the dependent variable decreases with time (e.g., capacity or power loss).

At this stage in the software development, only calendar-life data in units of time (e.g., weeks, months, years, etc.) are considered for fitting. At some future date, cycle life data should also be implemented in the software tool as well. The time unit is selected using the drop-down box under "Increases with time."

![Figure 29. Typical display to associate data and variables](image)

### 5.6.3.3 Specify the Equations

The life and transform equations must be entered next. The form of the equations must be of the appropriate mathematical operations and functions. The “Help” button will identify the available algebraic symbols, as shown in Figure 30. Do not include an equal sign (i.e., “=” at the beginning of the expression.

Assuming a linearizable model, Figure 31 shows the dialog box for specifying the equation and transforms. The linearized form of the life equation is entered in the upper text box marked “Modeling equation” and the terms of the equation are to be entered in the group of text boxes labeled as “Transform equations.” The number of transform equations will depend on the number of independent variables identified in Section 5.6.3.1. Using the example variables that have been identified (e.g., resistance, time, and temperature), the equation for default model is \( R = 1 + \exp(b_0 + b_2/\text{temp})t^{b_1} \) (i.e., Equation (2)). The “Default Model” button in the dialogue box will automatically fill in the text boxes with the appropriate model and transforms using the variable labels identified in Section 5.6.3.2. The linearized form is, therefore, \( \ln(R-1) = b_0 + b_2/\text{temp} + (b_1)\ln t \). The terms containing the three variables are entered in the boxes; the fitting constants, \( b_0 \), \( b_1 \) and \( b_2 \), are not entered. The order in which the transform equations are entered does not matter. The equations are not case sensitive and there is no limit to the number of terms in them. To confine the fit to a predetermined value, (e.g., a fixed power of time such as
a square-root of time dependence), the fitting equation would be
\[ R = 1 + \exp(b_0 + b_1/\text{temp})^{0.5} \] and the transform equations would not change.

The nonlinear form of the life equation is also entered in the upper text box marked “Modeling equation,” and must contain all of the independent variables identified in the previous step (Section 5.6.3.2). This model form will not require any transform equations. As with the linearizable model in Figure 31, the “Default Model” button in the nonlinear dialogue box will automatically fill in the text box with the model provided in Equation (5).

![Available algebraic functions](Figure 30. Available algebraic functions)
Figure 31. Typical display to specify equations and variable transforms for a linearizable model

It should be noted that there is no default model, linearizable or nonlinear, which depends only on time. In this case, the Default Model button will be grey and inactive. When the model equation is appropriately specified in the dialog box, click on "Next >" and the application will check the syntax of the modeling equation and report any errors. If the modeling equation uses negation after an open parentheses, as in “(-B0” , the application will report the error, "missing argument near ’)’." This is how the equation parser works. If the expression is preceded, instead, by a space, as in “( -B0”, then no syntax errors will be reported. After the syntax check, a message box will appear to confirm the names of the fitting variables. In the example shown in Figure 31, these are B0, B1 and B2. Click OK to proceed to the next step or Cancel to correct.

5.6.3.4 Import Test Data

The next step in the Fit Wizard is to import data from an Excel workbook or comma-separated value file. The data must be arranged in columns and normalized to time \( t=0 \) (see Section 5.4 for data formatting requirements). Additionally, if the relative change between measurements is greater than 50% (increase or decrease), the error model strategies will not be applicable and the user will then see a warning to this effect and have the option of continuing or not. Figure 32 shows a typical display for file selection. Only one file can be selected at a time.

Once a file has been selected, the wizard will produce a display similar to that shown in Figure 33. In this example, an EXCEL workbook was selected as the data file, so the worksheets names are shown on the left side of the display. Clicking on the worksheet with the data of interest produces a display similar to Figure 34. If an error was made in the file selection, click “Open another file...” to change source data. A similar display will be shown if data are read from a comma-separated-values file.
Figure 32. Typical display to select a data file

Figure 33. Typical display to open an Excel file

Figure 34. Typical display for selecting the sheet and columns from an EXCEL data file
In Figure 34, the “Use This 2” worksheet is selected. In this case, the program displays the contents of the first two rows of the selected sheet in the preview window, allowing for easier column selection. Data are selected by clicking on the first cell of the column. For the example shown in Figure 34, the relative resistance data are in column C; time, column A and temperature, column B. They were selected by clicking on those columns in that order. The arrow (>) shows the active variable name. The columns selected are shown in the window on the right side of the display. If a mistake is made, continue choosing columns until display cycles back to where the error is and click on the correct column. It is assumed that the time data are in calendar years and that the temperatures are in Celsius or Kelvin. If the temperatures are in Celsius, the program will convert them to Kelvin (Section 5.6.3.2).

### 5.6.3.5 Select Stress Factor Combinations

After the data are imported, they will be analyzed and grouped according to the stress factors previously identified (see Figure 28). There is also an opportunity to include or exclude a set of stress conditions if the data are not well-behaved. Figure 35 shows the display for this step using temperature as an example stress condition. Following this step, the software proceeds to the fit, and the results can be displayed as shown in Section 5.7.

![Figure 35. Selecting which stress factors to include in the fit calculation](image)

### 5.6.4 Simulation Wizard

Simulation is performed to calculate a life projection based on an assumed model, and, if experimental data are available, to judge the lack of fit between the test data and the model. As with the Fit Wizard (Section 5.6.3), the Simulation Wizard assumes time is an
independent variable for all modeling equations. The simulation process is shown below. The first three steps are the same as the Fit Wizard, and the corresponding descriptions can be found in Sections 5.6.3.1 through 5.6.3.3. The remaining steps are described in this section.

1. Define the data to be used
2. Associate variables to the data parameters
3. Specify the life equation and the corresponding transforms
4. Enter simulation parameters
5. Specify simulation conditions
6. Perform the simulation

With each dialog box in the Simulation Wizard, the user can move forward to the next step by clicking the “Next” button. If not all of the entries were appropriately filled, the software will prompt the user for the missing information. To update or modify a previous entry, press the “Back” button to return to the previous screen.

5.6.4.1 Enter Simulation Parameters

The parameters affecting the simulation results are entered using the form shown in Figure 36. Most of the fields will be automatically filled in by the software program from the Fit Wizard (Section 5.6.3), though the user must enter a value for the relative performance at end-of-life for the selected degradation parameter (e.g. a 30% increase in relative resistance resulting in a value of 1.3). The other fields can also be adjusted as necessary. If, for example, the measurement error is independently determined (Section 2.4.2), then this value can replace the estimated error calculated from the experimental data. Adjustments to the other parameter values, however, are not recommended if the user wants the simulation to replicate the actual experiment as closely as possible. The values for the initial parameter should be filled in based on expected performance. For example, if the model generally assumes a square root of time dependence, the value for “B1” in Figure 36 should be close to 0.5. Additionally, the estimated life of the batteries will be compared to the goals established by the U.S. Advanced Battery Consortium (USABC); in this case, the goals are associated with a hybrid-electric vehicle (HEV). The established vehicle goals for both calendar and cycle life are selected by the Goals drop-down box.
5.6.4.2 Specify Simulation Conditions

The experimental conditions (temperature, duration, number of cells, etc.) are then specified for all groups, as indicated in Figure 37. There is no limit to the number of groups that can be used, but the total number of cells in the simulation is limited to 500. The Monte Carlo simulation parameters for life prediction are also entered at this stage. These values include the temperature (in Kelvin), the upper and lower confidence limits,
and the number of simulation trials. Click on “OK” to perform the simulation and life prediction.

![Figure 37. Experimental conditions and Monte Carlo parameter entry](image)

### 5.6.5 Model Fit Results

The results from the model fit can be found by clicking on View ➤ Results of Models ➤ Fitting (Ctrl+Shift+G). An example result is shown in Figure 38 and includes the model equation, the names and variables that were used, the values of the fitting parameters, the estimate of errors, and lack-of-fit information. The values given in parentheses for each of the fitting parameters are the bootstrap standard errors determined from the Monte Carlo simulations. The values given in the error model section, \( \sigma_e^2 \) and \( \sigma_d^2 \), represent the variances of the measurement error and cell-to-cell effects, respectively. They are derived from the regression of the variance of the experimental dependent variable, \( Y \), on \( (\hat{\mu} - 1)^2 \), where \( \hat{\mu} \) is the predicted value of \( Y \). The values for \( Var(Y) \) and \( \hat{\mu} \) are computed for each experimental condition (e.g., temperature/time) to form the data set used in this regression. Alternatively, the measurement error will reflect the independently determined value, as discussed in Section 2.4.2.

The value of the lack-of-fit statistic obtained with the actual data is compared with the empirical cumulative distribution function (CDF) of the values obtained from the simulation trials to assess model inaccuracy. If the lack-of-fit statistic obtained with the actual data exceeds the percentile of the simulated values, then it can be concluded that the model is inaccurate. Normally, a small value for \( \alpha \) is selected (e.g., 0.01). In practice, the CDF is evaluated at the value of the lack-of-fit statistic (\( SS_{LOF} \)) obtained with the actual data. If the evaluated CDF point exceeds \( (1-\alpha) \), then it is concluded that there is evidence for lack of fit. Pressing the "View CDF" button will display the empirical CDF curve and the evaluated CDF point as shown in Figure 39. The empirical CDF curve may take some time to display fully.
Figure 38. Example results from fitting display
5.6.6 Monte Carlo Simulation Results

5.6.6.1 Life Estimation

The results of the Monte Carlo simulation can be found by clicking on View ► Results of Models ► Monte Carlo simulation (Ctrl+Shift+S). Figure 40 shows an example of life estimation when using experimental data (i.e., a life estimate with an upper and lower confidence limit). If a life estimate is based only on simulation data, the resulting prediction will typically be displayed as shown in Figure 41.
5.6.6.2 Data Plots

As mentioned in Section 5.5.4.2, there are five data plots available in the View ➤ Plot... ➤ menu option. Figures 42 through 47 show representative plots for each of the available options based on a set of experimental test data and a linearizable parameter fit using the default model in Section 2.2. A sample Fitting Results plot, which includes both experimental data and the resulting model fit, is shown in Figure 42. The numbers on the right of the model output indicate the corresponding test temperature (in Kelvin).
An example plot of the error model results (i.e., $\text{Var}(Y) \text{ vs. } (\hat{\mu} - 1)^2$) is shown in Figure 43, where $\hat{\mu}$ is the estimated performance. A plot of $(\bar{Y} - \hat{\mu})$ vs. $\hat{\mu}$ is shown in Figure 44, where $\bar{Y}$ is the average relative value and $\hat{\mu}$ is the estimated value. A plot of $\hat{\mu}$ vs. $\bar{Y}$ is shown in Figure 45. Finally, there are two different viewing options for the Monte Carlo simulation. Figure 46 shows the sample cell-distribution bar chart and Figure 47 displays the same data as a smooth curve. These plots indicate that over 50% of the cells have a predicted life of about 10 years or more.

Figure 43. Error model results
Figure 44. Difference between average and predicted performance vs. predicted performance

Figure 45. Predicted performance behavior vs. the average measured performance
Figure 46. Cell distribution bar chart

Figure 47. Cell distribution bar chart as a smooth curve
5.6.7 Report Preview

A preview of the results assembled by the software can be found by clicking File ➤ Preview Report (Section 5.5.1). The first page of a sample report is shown in Figure 48. This is useful in viewing the report prior to printing it on paper. The '<Prev' and 'Next>' buttons on the upper left allow navigating between and among a multi-page report.

Figure 48. Report print preview
5.7 Troubleshooting

The following section identifies known issues with the software development as of the publication of this manual, and their associated solutions.

5.7.1 Text-entry boxes and/or buttons are not in the correct positions or appear to be crowded

Solution: Change the settings for the display. Close the application. Right click on the desktop and select properties. Click on the tab that says Settings. Click on the button that says Advanced. Change the DPI setting in the Display group box to 96 DPI. Click OK twice.

5.7.2 The application is running on a network and an error occurs when trying to open a Life file

Solution: A message box similar to the one shown in Figure 49 should appear. This error occurs only when the application is running on an intranet. Download the .NET 2.0 SDK from Microsoft and follow the install instructions given in http://technet.microsoft.com/en-us/library/bb742442.aspx. Reboot the computer. Click Start -> Programs -> Administrative Tools -> Microsoft .NET Framework 2.0 Configuration. Click on the 2.0 Configuration snap-in followed by OK. Click on Configure Code Access Security Policy -> Adjust Zone Security -> Make changes to this computer -> OK -> Local intranet. Move slider to Full Trust. Click Next -> Finish. Close the configuration tool window. The application should run normally now.

![Network error box](image)

Figure 49. Network error box
6. REFERENCES


17. J. Belt, V. Utgikar, and I. Bloom, “Calendar and PHEV cycle life aging of high-energy, lithium-ion cells containing blended spinel and layered-oxide cathodes,” *J. Power Sources, 196*, 10213-10221 (2011).
Appendix A

Methods for Estimating the Parameters of Linear Models
Appendix A

Methods for Estimating the Parameters of Linear Models

1. INTRODUCTION

This appendix summarizes the statistical methodology used for estimating the parameters associated with linear degradation and error models. A linear model that can be represented by the form shown in Equation (A1) is assumed, where \( Z \) is a response variable, the \( X_i \)'s represent \( M \) explanatory variables, and the \( \beta_i \)'s are model parameters which are to be estimated. To achieve this linear form, it may be necessary to transform the natural response and/or one or more of the natural explanatory variables to a linear form. For example, the response could be transformed as shown in Equation (A2), where \( Y \) is the underlying performance metric (e.g., relative resistance). Other transformations could also be applied to explanatory variables, such as the inverse temperature.

\[
Z = \beta_0 + \beta_1 \cdot X_1 + \beta_2 \cdot X_2 + \ldots + \beta_M \cdot X_M \quad (A1)
\]

\[
Z = \log(Y - 1) \quad (A2)
\]

For estimating model parameters \( (\beta_i) \), it is assumed that there are \( N \) observations, each containing the observed value of the response variable, \( Z \), and the associated values of the explanatory variables, \( X_i \) (e.g., inverse temperature). Thus, the data consist of a set of observations, as shown in Equation (A3). The model parameters are then estimated by using a robust linear regression procedure (Reference 12). The purpose of using a robust regression procedure rather than ordinary least squares is to reduce the influence of anomalous data on the parameter estimates.

\[
\{(Z(i), X_1(i), X_2(i), \ldots, X_M(i)) : i = 1, 2, \ldots, N\} \quad (A3)
\]

An illustrative example of this methodology is provided in Reference 6.

2. ROBUST LINEAR REGRESSION

Two specific cases for estimation are considered. In the first case, the model contains an intercept term \( (\beta_0) \). Here, the initial step is to compute the average and standard deviation of each of the explanatory variables, \( X_i \). This yields \( \{\overline{X}_1, \overline{X}_2, \ldots, \overline{X}_M\} \) and \( \{S_1, S_2, \ldots, S_M\} \), respectively. These explanatory variables are then mean-centered and scaled as shown in Equation (A4). Therefore, in the case with an intercept, the design matrix (\( D \)) has a size of \( “N by M+1” \), and is of the form shown in Equation (A5).

\[
X^*_j(i) = \frac{X_j(i) - \overline{X}_j}{S_j} \quad (A4)
\]
In the second case for estimation, the model does not contain an intercept. Here, the explanatory variables are not mean-centered and/or scaled, and the design matrix \((D)\) has a size of “\(N\) by \(M\)”, and is of the form shown in Equation (A6).

\[
D = \begin{bmatrix}
1 & X_1^*(1) & \cdots & X_M^*(1) \\
1 & X_1^*(N) & \cdots & X_M^*(N)
\end{bmatrix}
\]  \hspace{1cm} (A6)

Once the design matrix has been determined, initialize a weighting matrix \((W)\) of size “\(N\) by \(N\)” with the identity matrix, and set \(Z = (Z(1), Z(2), \ldots, Z(N))\)^T, where \(Z\) is the response variable of the form shown in Equation (A2). Next, repeat the following matrix computations three times:

\[
b = \left( D^T \cdot W \cdot D \right)^{-1} \cdot D^T \cdot W \cdot Y \]  \hspace{1cm} (A7)

\[
R = Z - D \cdot b \]  \hspace{1cm} (A8)

\(W = \) diagonal matrix with elements from \(BIWEIGHT(R_1, R_2, \ldots, R_N)\)  \hspace{1cm} (A9)

The values for \(b\) in Equation (A8) are determined from Equation (A7) and the corresponding explanatory variables. In the first case (with an intercept), the estimated model parameters are given by Equations (A10) and (A11). In the second case (without an intercept), the estimated model parameters are given by Equation (A12).

\[
\hat{\beta}_0 = \left( b_0 - b_i \cdot \frac{X_1}{S_1} - b_2 \cdot \frac{X_2}{S_2} - \cdots - b_M \cdot \frac{X_M}{S_M} \right) \]  \hspace{1cm} (A10)

\[
\hat{\beta}_i = \frac{b_i}{S_i} \text{ for } i = 1: M \]  \hspace{1cm} (A11)

\[
\hat{\beta}_i = b_i \text{ for } i = 1: M \]  \hspace{1cm} (A12)

The \(BIWEIGHT\) function in Equation (A9) produces an \(N\)-dimensional output of weights from an \(N\)-dimensional input. It is based on Tukey’s biweight function with \(c = 6\) (Reference 13). Letting \(BIWEIGHT\{R_1, R_2, \ldots, R_n\}\) represent the biweight function and its input arguments, determine the weighting function as follows:
1. Compute the median absolute value (MAV) of the $R_i$'s determined from Equation (A8)

2. Compute standardized values of $R_i$'s as shown by Equation (A13)

3. $WEIGHT_i = 0$ if $Z_i \geq 1$ for $i = 1:n$

4. $WEIGHT_i = \left(1 - U_i^2 \right)^{1/2}$ if $Z_i < 1$ for $i = 1:n$

5. Return weights ($W$) to Equation (A9). The updated diagonal elements of $W$ are given by the values $\{WEIGHT_1, WEIGHT_2, \ldots, WEIGHT_n\}$.

$$U_i = Z_i \left/ \left( c \cdot MAV \right) \right.$$  \hspace{1cm} (A13)

### 2.1 Illustration of Linear Model Forms

The default degradation model has the linearized form shown in Equation (A14). This can be put into the form of Equation (A1) using Equation (A2) and the corresponding transformations shown in Equations (A15) through (A17), where the $X_i$'s are generic explanatory variables as defined by Equation (A3).

$$\log(\mu(T;t) - 1) = \beta_0 + \beta_1 \frac{1}{T} + \rho \cdot \log(t)$$  \hspace{1cm} (A14)

$$X_1 = \frac{1}{T}$$  \hspace{1cm} (A15)

$$X_2 = \log(t)$$  \hspace{1cm} (A16)

$$\beta_2 = \rho$$  \hspace{1cm} (A17)

The default error model has the linearized form given in Equation (A18), with the corresponding transformations shown in Equations (A19) through (A22).

$$Var\left(Y_i(T;t)\right) \approx \sigma_\delta^2 \cdot (\mu(T;t) - 1)^2 + \sigma_\pi^2$$  \hspace{1cm} (A18)

$$Z = Var(Y_i(T;t))$$  \hspace{1cm} (A19)

$$X_1 = (\mu(X_i;t) - 1)^2$$  \hspace{1cm} (A20)

$$\beta_0 = 2 \cdot \alpha^2 = \sigma_\pi^2$$  \hspace{1cm} (A21)

$$\beta_1 = \sigma_\delta^2$$  \hspace{1cm} (A22)
3. POSSIBLE COMPLICATIONS WHEN ESTIMATING ERROR MODEL PARAMETERS

Due to statistical fluctuations in the data, use of the estimation procedure might result in \( \hat{\alpha}^2 < 0 \) (i.e., \( \hat{\beta}_0 < 0 \)) or \( \hat{\sigma}_\delta^2 < 0 \) (i.e., \( \hat{\beta}_1 < 0 \)). Such negative estimates of variances can and should be regarded as nonsensical and the parameter estimates should be modified as discussed below.

3.1 Case 1: \( \hat{\alpha}^2 < 0 \)

In this case, the hypothesized measurement error was not detected. First, it is recommended that an alternative non-negative estimate for \( \alpha^2 \) be specified (i.e., \( \hat{\alpha}^2(alt) \)). This estimate could be based on an independent assessment of the measurement error (Section 2.4.2, References 10-11). If the measurement error variance is believed to be vanishingly small when compared to \( \hat{\sigma}^2_\delta \), then it might be prudent to consider \( \hat{\alpha}^2(alt) = 0 \).

Once the alternative estimate of \( \hat{\alpha}^2 \) is available, \( \hat{\sigma}^2_\delta \) must be re-estimated. This can be accomplished by first re-parameterizing the error model as shown in Equation (A23).

\[
Z = \text{Var}(Y_j(X; t)) - 2 \cdot \hat{\alpha}^2(alt) = \beta_1 \cdot (\mu(X; t) - 1)^2
\]  

(A23)

For purposes of regression, each observation again consists of \( Z \) and \( X_I \), where \( X_I \) is the same as defined in the first column of Equation (A6) and \( Z \) is now the “within-group” variance of the response minus twice \( \hat{\alpha}^2(alt) \). In this case, however, use the robust linear regression procedure without an intercept. The resulting estimated slope (\( \hat{\beta}_1 \)) provides the value for \( \hat{\sigma}^2_\delta(alt) \).

3.2 Case 2: \( \hat{\sigma}^2_\delta < 0 \)

In this case, the hypothesized random cell-specific proportional effect is not detectable. An alternative estimate for \( \alpha^2 \) can be determined with Equation (A24), where \( \{Y_1, Y_2, \ldots, Y_n\} \) are the \( n_j \) values of the response (e.g., relative resistance) for the \( j^{th} \) of \( N \) groups defined by stress condition and time. An alternative estimate for \( \hat{\sigma}^2_\delta \) would be to set it equal to zero, \( \hat{\sigma}^2_\delta(alt) = 0 \).

\[
\hat{\alpha}^2(alt) = \frac{1}{2} \cdot \sum_{j=1}^{N} \left( n_j - 1 \right) \cdot \text{Var}(Y_1, Y_2, \ldots, Y_n)
\]

\[
= \frac{1}{\sum_{j=1}^{N} \left( n_j - 1 \right)}
\]  

(A24)
Appendix B

Methods for Estimating the Parameters of Nonlinear Degradation Models
Methods for Estimating the Parameters of Nonlinear Degradation Models

1. INTRODUCTION

This appendix summarizes the statistical methodology used for estimating the parameters associated with nonlinear degradation models. A nonlinear model is generically represented by Equation (B1), where \( Z \) is a response variable, the \( X_i \)'s represent \( M \) explanatory variables, and the \( \beta_i \)'s are \( p \) model parameters which are to be estimated. For estimating model parameters \((\beta_i)\), it is assumed that there are \( N \) observations, each containing the observed value of the response variable, \( Z \), and the associated values of the explanatory variables, \( X_i \) (e.g., inverse temperature). Thus, the data consist of a set of observations, as shown in Equation (B2). The model parameters are then estimated by using the robust nonlinear regression procedure described below.

\[
Z = f(X_1, X_2, \ldots, X_M; \beta_1, \beta_2, \ldots, \beta_p) \quad (B1)
\]
\[
\{(Z(i), X_1(i), X_2(i), \ldots, X_M(i)) : i = 1, 2, \ldots, N\} \quad (B2)
\]

2. ROBUST NONLINEAR REGRESSION

The model parameters are estimated by using an iterative robust nonlinear regression procedure based on Tukey’s biweight function (Reference 13). The Levenberg-Marquardt algorithm (Reference 8) is used with each iteration to estimate the parameter values. The first iteration consists of ordinary nonlinear least-squares regression where the relative weights are identical. Subsequent iterations use updated weights that are computed from the biweight function.

For the first iteration, the Levenberg-Marquardt algorithm requires the user to supply initial guesses for the model parameters \((\beta_1, \beta_2, \ldots, \beta_p)\) and then searches to find parameter values that minimize the summation of the squared values of the residuals, as shown in Equation (B3). Residuals for the nonlinear model are computed the same way as the linearizable model case and based on the difference between the predicted and actual response variable; this is defined in Equation (B4). The predicted response variables, \( \hat{Z}_i \), are as shown in Equation (B5). The resulting estimated parameter values are denoted by \((\hat{\beta}_1, \hat{\beta}_2, \ldots, \hat{\beta}_p)\).

\[
\sum_{i=1}^{N} (\hat{Z}_i - Z_i)^2 \quad (B3)
\]
\[
R_i = \hat{Z}_i - Z_i \quad (B4)
\]
\[
\hat{Z}_i = f(X_1(i), X_2(i), \ldots, X_M(i); \beta_1, \beta_2, \ldots, \beta_p) \quad (B5)
\]
As with the linearizable model, a weighting matrix \((W)\) can be generated using the biweight function as defined in Appendix A, where \(W\) is a diagonal matrix with elements from \(BIWEIGHT(R_1,R_2,\ldots,R_N)\). The Levenberg-Marquardt algorithm is then re-applied (using the updated set of parameter estimates to begin the search) to find model parameter values that minimize the weighted summation of the squared values of the residuals, as shown in Equation (B6). The process of computing residuals, followed by updating weights and parameter estimates continues for a total of two more iterations to determine final estimates for the model parameters.

\[
\sum_{i=1}^{N} W_i \cdot (\hat{Z}_i - Z_i)^2
\]  

(B6)