MatSeis: A Seismic Toolbox for MATLAB

J. Mark Harris and Christopher J. Young
Sandia National Laboratories
work completed under DOE ST485D
sponsored by DOE

ABSTRACT

To support the signal processing and data visualization needs of CTBT related projects at SNL, a MATLAB based GUI was developed. This program is known as MatSeis. MatSeis was developed quickly using the available MATLAB functionality. It provides a time-distance profile plot integrating origin, waveform, travel-time, and arrival data. Graphical plot controls, data manipulation, and signal processing functions provide a user friendly seismic analysis package. In addition, the full power of MATLAB (the premier tool for general numeric processing and visualization) is available for prototyping new functions by end users. This package is being made available to the seismic community in the hope that it will aid CTBT research and will facilitate cooperative signal processing development.

Keywords: data visualization, signal processing, MATLAB, MatSeis

This work was supported by the United States Department of Energy under Contract DE-AC04-94AL85000.

DISTRIBUTION OF THIS DOCUMENT IS UNLIMITED
DISCLAIMER

This report was prepared as an account of work sponsored by an agency of the United States Government. Neither the United States Government nor any agency thereof, nor any of their employees, makes any warranty, express or implied, or assumes any legal liability or responsibility for the accuracy, completeness, or usefulness of any information, apparatus, product, or process disclosed, or represents that its use would not infringe privately owned rights. Reference herein to any specific commercial product, process, or service by trade name, trademark, manufacturer, or otherwise does not necessarily constitute or imply its endorsement, recommendation, or favoring by the United States Government or any agency thereof. The views and opinions of authors expressed herein do not necessarily state or reflect those of the United States Government or any agency thereof.
DISCLAIMER

Portions of this document may be illegible in electronic image products. Images are produced from the best available original document.
OBJECTIVE

During the course of CTBT related research efforts at Sandia National Laboratories, several project needs were identified. We determined that proper waveform processing would be very important to the success of a waveform correlation detector. Because our data is stored in an Oracle database, we needed database access to our library of MATLAB signal processing functions. We also noted that the performance of the detector could be verified easily if waveform data could be viewed in a time-distance profile superimposed with the travel-time curves used by the detector. In this format, all types of data are aligned in a natural coordinate system that is visually intuitive. While there are many excellent seismic software packages available, none could address all of our needs. ARS, Geotool, and dbpick are difficult to modify and contain limited signal processing libraries. SAC supports only basic graphing functions and has limited libraries. For this reason, we chose to develop our own MATLAB based software package, now known as MatSeis.

Using MATLAB as a basis has many advantages. It is a popular software package, robust, well supported, and available on many hardware platforms. In addition, it is an excellent prototyping environment, with built-in plotting functions and extensive signal processing functionality. Our data viewing needs could also be met easily with MATLAB graphics functions. MATLAB offers a mature, commercial software package with power and flexibility not available in the alternatives.

We have found MatSeis to be much more useful than we had anticipated. It is now widely used in the CTBT R&D program at Sandia and has been received favorably by others. We are confident this tool will aid others involved in CTBT research.

DEVELOPMENT

We developed MatSeis to meet the above objectives. MatSeis is a Graphical User Interface (GUI) programmed using MATLAB handle graphics. It provides an interactive time-distance profile display as a platform for data viewing and manipulation. Common GUI controls are provided such as menus, push-buttons, and mouse selections, all written in the MATLAB script language and C.

The initial MatSeis prototype was completed very quickly by taking advantage of MATLAB functionality. The prototype consisted of Oracle CSS 3.0 database access routines, a data profile display, and simple plot manipulation controls. Once the power of MatSeis was seen, its functions were expanded and performance improved to make it a more general seismic data visualization, processing, and analysis tool. We developed GUIs for reading and manipulating origin, waveform, travel-time, and arrival data. Interfaces to MATLAB and custom signal processing routines were added. Start-up configuration and system functions such as printing were also developed. Finally, we improved performance by converting often-used routines to compiled C MEX-files.

MATSEIS DESCRIPTION

MatSeis is executed from a command terminal window running MATLAB. The main graphical window has function menus at the top, push-button controls across the bottom, and the main time-distance display in the center. Figure 1 is an example screen print showing both the MatSeis display window and the MATLAB command window.

Since MatSeis is based upon MATLAB, the standard MATLAB environment is available from the command window. In fact, MatSeis is just a collection of functions which are executed in MATLAB. Anything done by a MatSeis GUI may also be done from the command line (although it may be very tedious), and data stored in MatSeis may be accessed on the command line for manual processing. For instance, raw waveform data may be entered directly into a prototype processing routine and the results plotted using MATLAB or entered back into MatSeis.

The main MatSeis display window consists of several linked plots showing the four basic types of data: origins, waveforms, travel-time curves, and arrivals. Origin IDs are displayed at the correct time in the upper plot. The central plot is organized as distance-from-origin vs. time, so
that travel-time curves are drawn in a familiar fashion. This plot shows waveforms aligned at the correct distance from the selected origin (79). Waveforms are superimposed over the travel-time curves. In this way phase arrival structure in the data is readily apparent.

Plot axis manipulation is easily performed using push-buttons at the bottom of the window. The plot may be resized by zooming in or out using the push-buttons. More detail may be examined by zooming IN on a rectangle drawn with the mouse. The zoom OUT functions expand the view to twice its original size. The DRAG functions allow the plot to be repositioned with the mouse. The MOVE functions move the view one-half screen in the direction selected. A 10-level undo function and several zoom short-cuts are also available.

Pull-down menus organize the functions available in MatSeis. The File and View menus give options for basic administration and window configuration. For example, grid lines on the main plot may be enabled using the View>Grid Lines options. A menu for each type of data contains options for reading and manipulating data items. An additional menu provides access to signal processing functions.

Many operations require parameters to be entered before the action is applied. These items may use a setup window like the Waveform>Read window shown in Figure 2. Menu items followed by an ellipsis (...) will generate a setup window. Typically, the Apply button must be pressed to execute these actions. Menu items with no ellipsis execute the action immediately.
Networks, Stations, and Channels are read from the current database

FIGURE 2. Waveform Read window.

In addition to pull-down menus and push-button zoom controls, each data object displayed may be selected with the mouse. When an object is selected by a mouse click, a small popup window appears (see Figure 3). This popup allows manipulation of the object. For instance, if the waveform ALEBHZ is chosen as shown in the figure, it may be selected for signal processing, its color may be changed, or it may be deleted from MatSeis memory.

DATABASE INTERFACE

While MatSeis was originally written to access an Oracle CSS 3.0 database, it is designed to be easily extended to other database types. It currently will also interface with CSS 3.0 flat files, and a set of templates is included for porting to a generic “Local” database. The database type and options are set from the File>Database Setup window. The database type may be changed at any time. All data read and write functions will use the database currently selected, so data from different sources may be combined using several read operations.

SIGNAL PROCESSING AND ANALYSIS

Signal processing is an important component of MatSeis. MATLAB provides a rich environment of signal processing functions, and new functions may be rapidly prototyped. MATLAB offers “toolboxes” of functions for many types of processing. Signal processing, statistics, wavelet, neural network, fuzzy logic, and many other toolboxes are available.

Many of the functions in the MATLAB Signal Processing Toolbox have been incorporated into MatSeis. For instance, digital filters may be quickly designed and applied to waveforms using the Signal Processing>Filters>Filter Design window (see Figure 4). This GUI combines all the filter design techniques included in the Signal Processing Toolbox, such as Butterworth, Cheby-
shev, Elliptic, and FIR. From the Filter Design window, you may check the filter performance by plotting frequency response, impulse response, and poles and zeros in the z-domain, then apply the filter to selected waveforms. Some typical seismic processing techniques have also been implemented in the current version of MatSeis, such as STA/LTA filtering, beamforming, and polarization analysis.

Waveforms are "selected" for signal processing operations using the waveform popup or the Signal Processing>Select options. When selected, the waveform label is highlighted. MatSeis will create new waveforms or replace the originals according to the Signal Processing>Options settings. The time segment operated upon may be set using the Signal Processing>Time Segment options. Operating upon short time segments will greatly reduce processing time. For example, to refine first arrival picks, you may align the plot on the P travel-time curve, select a time segment containing this curve, then apply a filter only to data containing the P arrivals.

In addition to filtering operations, signal analysis routines are also provided by MATLAB. For example, waveform spectrograms are easily computed using the Signal Processing>Analysis>Spectrogram function. See Figure 5 for an example of a spectrogram of about ten minutes of three of the waveforms shown in the previous figures. The plot was first aligned on P, which is clearly seen in all three spectrograms in this example.

FIGURE 3. Data object popup menus.
FIGURE 4. Filter Design window and Frequency Response plot.

FIGURE 5. Example Spectrogram output.
CUSTOMIZATION AND EXTENSION

MatSeis may be customized to start up with a specific configuration of origins, waveforms, etc. This may be set by environment variables or a configuration file. This technique may be used to spawn MatSeis from another program as a general seismic data viewer.

Also, templates are provided for adding signal processing functions and porting to new databases. New signal processing functions may be added to a custom pull-down menu or called from the command line. The database template files may be modified as needed and then used immediately (this is called the “Local” database).

Users at Sandia and other facilities are currently working to add functionality to MatSeis. Event detection, discrimination, and measurement topics are being addressed. Special functions of interest to the WCEDS project are also being developed, such as calculating the waveform correlation operation directly from MatSeis and generating empirical waveform stacks.

Since MatSeis is distributed as full source code, one can modify existing functionality as needed. New processing routines may be generated easily using examples which are prototyped within MatSeis. It is hoped that this program will encourage enhancements by end users, with feedback of new functions to the original software base at Sandia. Cooperative development will provide more functionality to all users.

AVAILABILITY

MatSeis is freely available to the CTBT community and the seismic community in general. It may be downloaded from the CTBT R&D WWW home page. The MatSeis home page contains links to compiled versions of MatSeis for several hardware platforms. The code may also be compiled for other platforms as needed. Effort has been made to make the code platform independent. Requirements for running MatSeis are MATLAB and the Signal Processing Toolbox. Compiling the source code for a new platform requires a C compiler.

MatSeis documentation and data examples are also provided on the Web page. A user’s guide is also included in the distribution. On-line documentation for each function is provided in the usual MATLAB fashion: type help function-name in the command window.

The MatSeis URL is http://www.ctbt.rnd.doe.gov/ctbt/data/matseis/matseis.html, or send e-mail to mharris@sandia.gov.

The MATLAB URL is http://www.mathworks.com.

CONCLUSIONS AND RECOMMENDATIONS

MATLAB has been very useful to the CTBT R&D project team at Sandia. MatSeis has provided better data access, manipulation, and algorithm prototyping than other available packages. Since this software has been well received by other CTBT research groups, it is being made available to the seismic community as a whole. It is hoped that additional features will be added to MatSeis in a synergistic way by any and all users. Sandia will help to make user enhancements available on the MatSeis home page.

REFERENCES
